miniDLNA in the guest network?

I need help at short notice,…

I would like to make the miniDLNA service available in the guest network, this also works without problems in my normal WLAN.

Also, I have already selected the guest network with Luci as a source offered, and the port of the miniDLNA server in the firewall released, unfortunately, the DLNA server in the guest network still does not want to be found.

Can someone help me, would otherwise be on the upcoming family festival more than annoying to take over even the DJ.

Greetings Felix

I don’t think that’s the logical intent. The guest network by definition does not have access to the LAN or to the clients on that network.
Therefore, mini DLNA cannot and must not serve such a network because the Guest network cannot access the media files on the LAN.

The alternative is my guests are in my own wifi with their Google data crawls

It’s not about the LAN, I have shared the dlna in the guest network, but probably another firewall lock takes effect there from the guest network. Since an access to the web interface also not possible.

So the question is, how do I set an exception only for the miniDLNA?

The whole thing via NFS server, will probably trigger the same!?

The first question is what do you want to achieve ?

As far as I know, DLNA is meant to make (stream) media available (in this case it is storage directly on the router). A NAS can serve a similar purpose if the DLNA server on it is activated.

“My reasoning may not be entirely accurate”

It is doable, actually I did, still guest is isolated but can reach only allowed resources such as minidlna.

The goal was to share a few photos on a family party on a projector. Has now unfortunately not worked, but is still interesting for the future.

Will you tell us how you implemented it?

What ports do you have allowed in firewall?

config rule
option dest_port ‘1900’
option src ‘guest’
option target ‘ACCEPT’
option family ‘ipv4’
list dest_ip ‘’
list proto ‘udp’
option name ‘guest-SSDP’

config rule
option dest_port ‘8200’
option src ‘guest’
option target ‘ACCEPT’
option family ‘ipv4’
list proto ‘tcp’
option name ‘guest-MINIDLNA’

Add these rules, just be sure to replace the network name, in my case it is “guest”, yours might be turris_guest if it is the default.

option src ‘guest’


I had probably only released the standard port 8200, which the minidlna service uses.

Will try it again the days, explicitly with additional release of the port 1900.

Thanks for your hints.

That 1900 is for SSDP service discovery protocol.

Let us know the results.

This topic was automatically closed after 60 days. New replies are no longer allowed.