"MediaTek MT7915E" radio doesn't work

Hi all,

I cannot make “MediaTek MT7915E” radio work. Unlike a few other thread here, it does show in the list, but none of my devices see it.

I tried all combinations of 802.11 N/AC/AX, 2.5GHz/5GHz and band width, also tried to bring devices very close to the router (for the case something is wrong with antennas) – nothing.

When I use external access point (something that I wanted to get rid of when bying Turris Omnia) – devices are capable to connect 5GHz 802.11ac.

Before I contact support for the return, is there anything obvious that I may miss?


The 2.5GHz “Generic MAC80211” radio works (kind of, I’ve created a separate thread to describe the issue).

Try to reset wifi settings in reForis. It should help.

Thanks for the suggestion.
I tried it, didn’t help unfortunately.

You can try to change mPcie slot to confirm that it is not broken. And then, as a last try I would suggest to reflash Omnia from medkit.

I won’t do either as I’m afraid to lose warranty and still hope to be able to return the router if it’s broken on arrival.

Oh, if it is that new, then try to return it, of course.