Mdadm 4.0 and RAID

raid

#1

Is RAID working for you after 3.11.0 update? What startup scripts do you use?
I have been using mixed setting of this community documentation https://doc.turris.cz/doc/en/public/create_a_raid_array and this forum help https://forum.turris.cz/t/help-with-setting-up-a-raid-system-with-turris-omnia-nas-for-a-beginner/1743/16. It seems mdadm update overwritten /etc/init.d/mdadm which is easy to fix. However it seems not enough. I still cannot run mdadm --assemble command. Can you share your startup script to run raid on 3.11?


Mdadm 4.0 monitor mode doesn't send email notifications
#2

Does anybody has a working setup for RAID after migration to 3.11? I was never successful to assemble existing RAID (I’ve never tried to create new one as I have data in RAID, so it might work on green field setup/creation). The only working setup for me was to do rollback to 3.10.8.


Turris OS 3.11 is out!
#3

Hi. I’m using RAID and did not noticed any issues.


#4

RAID is working almost fine for me, even after the update. I was using /etc/rc.local to start/monitor/mount the RAID, but now I’m using the /etc/init.d/mdadm init script which ships with the mdadm package. See /etc/config/mdadm for configuration options. The init script will generate mdadm config file, start your array and start mdadm daemon in monitoring mode (without the --test switch unfortunately).


#5

Thanks. It worked. I had to copy info from original /etc/mdadm.conf to /etc/config/mdadm and it works with new /etc/init.d/mdadm startup script. Ideallz community documentation should be rewritten now…


#6

I’m glad that helped. The community documentation currently mentions only a general approach for managing RAIDs, but I agree it should be enhanced with this more OpenWRT-specific approach using /etc/init.d/mdadm and /etc/config/mdadm.