Manually installed packages are getting uninstalled by updater and vice versa


I didn’t found any suitable threads or solutions for my problem. Today I’ve installed updates and restarted Omnia. After restart WLANs were not working - at first I was not able to figure out why so I made wireless cards reset from ReForis and I found afterwards that I’m not able to configure encryption due to missing hostapd. In the past I’ve played with various hostapd versions (openssl,wolf… ) when I’ve tried to configure DAWN.

I assume that’s the reason why WLANs wasn’t working after reboot as updater removed hostapd.
So I’ve installed “hostapd” and configured wlans from the scratch. I’ve also uninstalled docker. Everything this moring

Few hours later I’m getting following notification from turris updater:

Your approval is required to apply pending updates. You can grant it in the reForis administrative interface in the ‘Package Management — Updates’ menu.


• Install python3-websocket-client 0.57.0-3.9-2
• Install python3-texttable 1.6.3-3.9-1
• Install python3-dotenv 0.15.0-3.9-1
• Install python3-dockerpty 0.4.1-3.9-3
• Install python3-pynacl 1.4.0-3.9-6
• Install python3-paramiko 2.7.2-3.9-1
• Install python3-docker 4.4.1-3.9-1
• Install python3-docopt 0.6.2-3.9-2
• Install python3-cached-property 1.5.2-3.9-1
• Install docker 20.10.17-1
• Install docker-compose 1.28.2-3.9-1
• Install ttyd 1.6.3-3
• Install luci-lib-docker git-21.167.46325-83f6606
• Install luci-app-dockerman v0.5.13
• Install luci-i18n-dockerman-de git-23.021.36412-5965d2a
• Install luci-i18n-dockerman-en git-23.021.36412-5965d2a
• Install luci-i18n-dockerman-cs git-23.021.36412-5965d2a
• Remove hostapd
• Remove kmod-dm
• Remove kmod-dax
• Remove kmod-keys-encrypted
• Remove kmod-crypto-cbc
• Remove kmod-nf-ipvs
• Remove kmod-keys-trusted
• Remove kmod-crypto-sha1
• Remove kmod-tpm
• Remove kmod-random-core
• Remove kmod-asn1-decoder
• Remove kmod-asn1-encoder
• Remove kmod-oid-registry

Can someone please explain what’s going on ? Is docker part of default Turris OS ? Why it is getting installed back and why it want to remove hostapd (without installing any other hostapd variant) ?

Yes, I had the same issue, did not find where the problem is, but worked it around it by adding a configuration file to updater:

root@ar9:~# cat /etc/updater/conf.d/x-rainbow.lua
-- Use LED config in /etc/config/system instead of rainbow
-- Old docs, but still works:

If someone knows why is this that would be great to know.

1 Like

This is the way turris updater works. I.e. it knows the target state and does whatever is needed to get to it. And it is run once every 4 hours, so it makes sense it uninstalls the packages a few hours later after your manual changes.

However, at least for me, using opkg install automatically adds the manually installed package in the additional config file so that the updater does not revert my changes. I’m not sure why the Luci interface does not do the same.

1 Like

This topic was automatically closed after 60 days. New replies are no longer allowed.