LXC Debian pro Turris 1.1

Dobry den,
nasel by se zde nekdo ochotny mi pomoci rozjet LXC s Linuxem?
Vsechny navody na zprovozneni jsou zastarale a bohuzel nefunkcni.

Predem vsem mnohokrate dekuji, za jakoukoli informaci.

riesil som to par tyzdnov dozadu. Vyzera to, ze debian pre PPCSPE bol zarezany, takze uz pren neexistuje repo, cim sa zda, ze sme s turris v1.1 nahrani :confused:

Někde tady je odkaz na nějaký poslední stav repozitářů před ukončením té minimální podpory, co to mělo. Naposled jsem to instaloval odtamtud. Ale bylo to problematické někde kolem libc , takže standardní věci nešly rozchodit. A TurrisOS/OpenWRT se pomalu zlepšuje, tak jsem se na to vykašlal.
Mám ten repozitář najít v konfiguraci toho modráka? Musel bych najít disk, kde to bylo…

S podporou LXC kontejnerů pro procesory PowerPC na které jsou postavené routery Turris 1.0 a Turris 1.1 je to problematické jelikož došlo řekl bych k odstranění experimentální podpory powerpcse z Debian ports. Proč k tomu došlo je možné se dočíst v tomto e-mailu: https://lists.debian.org/debian-powerpc/2019/05/msg00128.html

Myslím si, že s podporou OpenWrt 18.06/19.07 na routerech Turris 1.0/1.1 to bude zase o něco lepší z důvodu toho, že mnoho balíčků pochází přímo z repozitářů OpenWrt a mimo jiné bude možné si zkompilovat nástroje, bez velkého úsilí jak doteď, potřebné pro buildění balíčků přímo pro OpenWrt, následně balíček vytvořit/aktualizovat, otestovat a poslat do upstreamu, aby to bylo dostupné všem.

Samozřejmě také zůstane možnost požádat o nejnovější verzi pomocí issue na našem Gitlabu/na Githubu OpenWrt, případně i zde.

1 Like

Ahoj,
taky jsem to chtěl zkusit a nasel jsem na fóru správný repositář.
https://snapshot.debian.org/archive/debian-ports/20190518T205337Z/
Potom na https://wiki.turris.cz/doc/cs/public/lxc
lze upravit příkazy:

debootstrap --include=debian-ports-archive-keyring --arch=powerpcspe sid rootfs https://snapshot.debian.org/archive/debian-ports/20190518T205337Z/

echo “deb https://snapshot.debian.org/archive/debian-ports/20190518T205337Z sid main” | cat >> ./rootfs/etc/apt/sources.list

a kontejner se nainstaluje…

Potom jsem pokračoval dál…chtěl jsem si nainstalovat pyLoadu do tohoto kontejneru dle návodu
https://wiki.turris.cz/doc/cs/public/pyload_lxc
ale skončil jsem u prvního bodu (pro Turris 1.x)
Nejde mi nainstalovat balíček git. Ostatní balíčky jsou v pohodě.

Dostávám tuto hlášku
root@debian1:~# apt-get install git
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
git : Depends: git-man (< 1:2.19.1-.) but 1:2.20.1-2 is to be installed
Recommends: patch but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Odinstaloval jsem verzi 1.2.20…,ale nevím jak přidat starší verzi
root@debian1:~# apt-get install git-man=1:2.19.1-1
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Version ‘1:2.19.1-1’ for ‘git-man’ was not found

a přitom v repositáři by měl být
http://snapshot.debian.org/archive/debian-ports/20190518T205337Z/pool-powerpcspe/main/g/git/

Mužete mi poradit jak dál?
Díky.