LTE Modem installation problem!


I tried to install LTE modem to establish internet connection according to following link:

Have installed kmod qualcomm package but still nothing, it won´t connect.

Any help possible?


I am also not able to get the Quectel EC20 mini-PCI card to work. The card is not being identified by the lspci application. I have swapped PCI slots with one of the wifi cards and the wifi card is correctly identified in either PCI slot. However the Quectel card is not identified in either PCI slot. The Quectel card seems much more loose as it is slipped into the PCI slots than the wifi cards. Turris Omnia please respond here and to my email. Thank you.

lspci doesn’t show the card but lsusb should show it:

Bus 001 Device 002: ID 05c6:9215 Qualcomm, Inc. Acer Gobi 2000 Wireless Modem

Hi White, Thanks for info on your lspci experience! Nothing in lsusb either and no USB device in /dev. I think I have the necessary usb drivers installed, could you review to your install? :

uqmi -d /dev/cdc-wdm0 --get-signal-info
Failed to open device

Hostname turris
Model Turris Omnia
Firmware Version OpenWrt omnia 15.05 r49274 / LuCI 3200f7dc985b1ac048a62a96ffae783b3c285448 branch (git-16.212.24666-3200f7d)
Kernel Version 4.4.13-05df79f63527051ea0071350f86faf76-9

Remove kmod-usb-core 4.4.13+9-1-05df79f635…6-9
Remove kmod-usb-net 4.4.13+9-1-05df79f635…6-9
Remove kmod-usb-net-cdc-ether 4.4.13+9-1-05df79f635…6-9
Remove kmod-usb-net-qmi-wwan 4.4.13+9-1-05df79f635…6-9
Remove kmod-usb-net-rndis 4.4.13+9-1-05df79f635…6-9
Remove kmod-usb-serial 4.4.13+9-1-05df79f635…6-9
Remove kmod-usb-serial-option 4.4.13+9-1-05df79f635…6-9
Remove kmod-usb-serial-qualcomm 4.4.13+9-1-05df79f635…6-9
Remove kmod-usb-serial-wwan 4.4.13+9-1-05df79f635…6-9
Remove kmod-usb-storage 4.4.13+9-1-05df79f635…6-9
Remove kmod-usb-storage-extras 4.4.13+9-1-05df79f635…6-9
Remove kmod-usb-uhci 4.4.13+9-1-05df79f635…6-9
Remove kmod-usb-wdm 4.4.13+9-1-05df79f635…6-9
Remove kmod-usb2 4.4.13+9-1-05df79f635…6-9
Remove kmod-usb3 4.4.13+9-1-05df79f635…6-9
Remove kmod-veth 4.4.13+9-1-05df79f635…6-9
Remove kmod-wdt-orion 4.4.13+9-1-05df79f635…6-9

# uqmi -d /dev/cdc-wdm0 --get-signal-info
“type”: “hdr”,
“rssi”: -125,
“ecio”: 5,
“io”: -106,
“type”: “wcdma”,
“rssi”: -82,
“ecio”: 9

# uname -a
Linux turris 4.4.13-05df79f63527051ea0071350f86faf76-9 #1 SMP Tue Nov 1 17:21:36 CET 2016 armv7l GNU/Linux

# opkg list-installed | grep -i kmod-usb
kmod-usb-core - 4.4.13+9-1-05df79f63527051ea0071350f86faf76-9
kmod-usb-net - 4.4.13+9-1-05df79f63527051ea0071350f86faf76-9
kmod-usb-net-cdc-ether - 4.4.13+9-1-05df79f63527051ea0071350f86faf76-9
kmod-usb-net-qmi-wwan - 4.4.13+9-1-05df79f63527051ea0071350f86faf76-9
kmod-usb-net-rndis - 4.4.13+9-1-05df79f63527051ea0071350f86faf76-9
kmod-usb-serial - 4.4.13+9-1-05df79f63527051ea0071350f86faf76-9
kmod-usb-serial-option - 4.4.13+9-1-05df79f63527051ea0071350f86faf76-9
kmod-usb-serial-qualcomm - 4.4.13+9-1-05df79f63527051ea0071350f86faf76-9
kmod-usb-serial-wwan - 4.4.13+9-1-05df79f63527051ea0071350f86faf76-9
kmod-usb-storage - 4.4.13+9-1-05df79f63527051ea0071350f86faf76-9
kmod-usb-storage-extras - 4.4.13+9-1-05df79f63527051ea0071350f86faf76-9
kmod-usb-uhci - 4.4.13+9-1-05df79f63527051ea0071350f86faf76-9
kmod-usb-wdm - 4.4.13+9-1-05df79f63527051ea0071350f86faf76-9
kmod-usb2 - 4.4.13+9-1-05df79f63527051ea0071350f86faf76-9
kmod-usb3 - 4.4.13+9-1-05df79f63527051ea0071350f86faf76-9

Thx for info. Our OS & driver levels look the same. I will wait to hear back from my request to the tech support folks. It is usually a software config issues rather than hardware, but if the case here I am really blind to something.

Actually, I have noticed that the LTE card should be configured differently, than described on Wiki. You need to use its QMI interface. This is what I did:

  1. logged through SSH
  2. uqmi -d /dev/cdc-wdm0 --start-network your_apn_name --autoconnect
  3. Check if connected: uqmi -d /dev/cdc-wdm0 --get-current-settings
  4. In LuCI UI: Create new interface and point it to wwan0, set DHCP.


I have by me installed a sierra wireless mc7710 and had to start similar problems.
under “ls /dev” not shown ttyUSB* or cdc-wdm0,
i figured out that the card operates either in QMI or DIP (Direct IP) mode, too identify what mode my card is in check the ProductID under “lsusb” show my LTE card with tihs address: 0x68a3, running in DIP mode

0x68A2 = QMI
0x68a3 = DIP

I have change this with an windows exe from DIP to QMI mode, after this i have build in to my turris omnia router and now i have under “ls /dev” ttyUSB* and cdc-wdm0 :smiley:

here is a helpful link about configuring 3G/4G cards

Hi. Was there a solution to this? I’m in the same boat. LTE modem installed, but it doesn’t appear in the UI nor the output of lsusb. Kernel module is loaded, kernel version 4.4.38.

Hi all,

Are there any news on this?

I am running into the same problem on 4.4.39-80079e1c1e5f9ca7ad734044462a761a-4.

Nothing shown in lsusb or lspci, so no /dev/ttyUSB* or /dev/cdc*

Thanks and regards,


P.S. @Vaclav, sorry for spamming you, hope this is the correct way to get support for officially supplied hardware that’s not working.

1 Like

be sure that this is not spamming, I’ll gladly help!

E-mail directly to the support is usually better way, but this issue is well documented in this topic, I’ll forward this to our developer.

Kind regards,

Just to be sure: Do you have the LTE modem in the right-most PCIe connector (the one with the SIM slot below the card?). It is the only PCIe slot with populated USB pins and with SIM pins.


Hi! I got the original Omnia with the LTE perk.
The performance with the offered modem is very disappointing.
Got it to work when i received the Omnia, but it soon stopped working with the first system update.
Seems to be a general problem that is not being addressed by the community :frowning:


There are many users using the Omnia with LTE modem. We also tested it personally in the Czech Republic and Germany. Without any problem with performance.

Please, open a support ticket, we’ll gladly help. I am also moving your post to the correct thread.

Solved the problem when installing an external sim card socket. Seems that the sim card was not correctly or connecting completely with pads…

Thx for your attention and initiative.

1 Like

Thank you for getting back to us, I’m happy to see that you have your setup up and running.

Kind regards and closing the topic as solved. In case you have anything else we can help with, don’t hesitate to drop a line again.