LTE disconnected on change


first i want to tell that this is the best router i ever used in my live. All worked well from the start, including the installation of the LTE-Modul, which i followed exactly your tutorial.

I also bought the same card as in the LTE-Pack, the Quectel EC20, so i don’t have to fuzzle around with drivers.

But when i change specific things on my router, the LTE-Cars stops working and will only work again, if i do the following steps:

  • delete the whole interface (LTE)
  • shutdown
  • remove the card
  • reboot
  • mount the card again
  • reboot
  • install the LTE-Interface again

Otherwise the LTE-Symbol is greyed out in Luci and only RX and TX appear. No Uptime, MAC-Address and IPv4 stats.

Deleting the interface without removing the card didn’t work.

I have factory resetet the router like 5 times and tried to reproduce the bug.

I could reproduce it with the following:

  • When i configure in LUCI the LED’s for either the USB-Device or the netdev for the LTE-Interface AND renamed the Led’s, so it will not be resetet to default on reboot.

  • Change the SSID for the 5 GHz or the 2,4 GHz Wifi

  • Added a Guest-Wifi

So the best way would be to make all the changes to an Interface BEFORE setting up LTE, so you don’t run into trouble. This was exactly how i did it the first time i set up the router, so i didn’t ran into any problems.

But yesterday i had to change something, so i encountered this behaviour, which can be fixed with the steps above, but it cost me some time to figure that out.

I am not at home at the moment, so i have not any logs from my connection, but i can provide it, if necessary.

Edit: spelling


After days of testing, i came to the conclusion that the temp was the problem, the LTE Card simply got to hot, when under load, combined with the hot temps in the last weeks. So i applied a self build cooler, similar to that provided in the LTE Pack, a sawed aluminium piece. Now it works even under heavy load, without disconnecting. I would not have thought that this could be the problem, seems like a design flaw from the producer of these LTE-Cards, because my Smartphone can provide me with similar Speed, without the need for a Water-Cooling-Solution, and the LTE-Function from my smartphone is only one part of a complex computer-system.

But i am happy that my LTE now works and i could get rid of my “we don’t provide updates, our software is perfect from day 1” - Modem.

Edit: the bugs, when configuring interfaces still persist, but are minor, since you do not configure it on a daily base, but can be hard to track down.

My LTE Connection also fails on heavy load. When I download more than 200mb the LTE Modem stops working and only works again, if I shutdown the device and completely remove the power cord, a reboot doesn’t work.

In your description you say that the Quectel EC20 can get very hot, but I don’t think that is the problem, if an LTE Card, which is made for Laptops don’t work without an external cooling solution, it shouldn’t be sold in the first place.

Has someone similar behavior with the LTE Pack, or is my LATE card broken?

These bugs I stated above still persist.

I also experience problems with the Lte.
Take a look here
I also experienced a problem with the card but I am not sure yet which is the problem exactly. I tested with a different provider and it worked. Maybe it was/is a provider network issue. I need to test a bit more and i will report back here

Thanks for reply.

I could isolate the applications which cause the error.

  • bittorrent
  • steam downloader
  • windows update
  • bitcoin or other crypto-currency-wallets syncing

which are all applications where uploads are involved.

Where for example netflix streaming results never in connection loss.