Lost HDD UUID in NAS perk


I have noticed problem with one of my HDDs (Seagate BarraCuda 5TB ST5000LM000, ext4) in Omnia NAS perk (TOS 6 HBL) after router disassembly (I was connecting only ipex cables to new diplexers).
First, both HDDs were not accessible. Then I have disassembled it again, to make sure all cables are connected. After each restart, everytime, another HDD was like disconnected in LuCI (Mountpoints). I have disassembled it for 3 times at all, and after few reboots both HDDs showed up.

I thought everything is ok, but next day, one of them dissappeared again. It is visible in Storage plugin without UUID, but in LuCI mountpoits it is not visible. I cannot add it there, so it seems to be dead in some way.

blkid or hdparm does not show info about that disk

Data on that disk are important, but not very critical for me (I dont want to format it for now).

My question is:
Is there some another way to find out what happened, before I try to change HDD PCB from working disk (both are the same) to that with lost uuid?.
Or shoud that problem be in mpcie to sata converter?

Thanks for any advice.

Little update:

Router disassembled again, tried reboots with only one disk connected. Both disks were working. Then tried to connect both disks at once and result is: both disks are working.

So, it seems that problem is either in minipcie to sata converter (really dont know how to test this) or there was some weird update related to disk mount.