Loop in the network

I am on Omnia with Turris OS 6.2.4. The kernel keeps sending this message. It wasn’t there before.

br-lan: received packet on lan0 with own address as source address (addr:xxxxx, vlan:0)

Of course it is a loop in the network, the MAC address is that Omnia itself. What could it be? Is something broken?

On port LAN1, i.e., lan0, I have the first of the nodes in my mesh network. It is a Linksys router used in bridge mode with four other identical nodes scattered around the house, always used as access points and connected to the main node via WiFi.

EDIT: af_packet: tpacket_rcv: packet too big, clamped from 33174 to 32638. macoff=82
Added to the earlier error was this other message.

Provide some diagram how your devices are connected and I might help

All devices are connected to the router via mesh network Wi-Fi. Nothing else is connected to the physical LAN ports of the Turris Omnia.

Ok now how is your mesh connected and post /etc/network/config obscured


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxx:xxxx:xxx:xxx/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan0'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ip6assign '60'
	option _turris_mode 'managed'
	list ipaddr '192.168.1.1/24'

config interface 'wan'
	option proto 'pppoe'
	option username 'xxxxxxxxxx'
	option password 'xxxxxxxxx'
	option device 'eth2.835'
	option ipv6 '0'
	option defaultroute '1'
	option metric '10'

config interface 'wan6'
	option device '@wan'
	option proto 'none'

config device 'dev_wan'
	option name 'eth2.835'

config interface 'guest_turris'
	option enabled '1'
	option proto 'static'
	option device 'br-guest-turris'
	option ipaddr '10.111.222.1'
	option netmask '255.255.255.0'
	option ip6assign '64'

config device 'br_guest_turris'
	option name 'br-guest-turris'
	option type 'bridge'
	option bridge_empty '1'

config interface 'lte'
	option proto '3g'
	option device '/dev/ttyUSB2'
	option service 'umts'
	option apn 'xxxxxx'
	option ipv6 'auto'
	option defaultroute '0'

config route 'lte_route'
	option interface 'lte'
	option target '0.0.0.0'
	option gateway '10.64.64.65'
	option netmask '0.0.0.0'
	option metric '50'

config interface 'wg0'
	option proto 'wireguard'
	option private_key 'xxxxxxxxxxx'
	option listen_port 'xxxxxxxxxx'
	list addresses '10.0.10.0/24'

config wireguard_wg0
	option public_key 'xxxxxxxxxx'
	option preshared_key 'xxxxxxxxx'
	option route_allowed_ips '1'
	list allowed_ips 'xxx.xxx.xxx.xxx/32'
	option persistent_keepalive '25'
	option description 'xxxxxxxxxx'

As I have shown, the mesh network starts from the LAN0 port of Turris Omnia and propagates via the WiFi backbone network of the various Linksys nodes. So the first node is physically connected with an Ethernet cable to the only LAN port used on the Turris Omnia, and the other nodes connect via WiFi to the main node.
Plus I forgot that I re-enabled the router’s WiFi 6 network, which I use mainly for guests. I had tried disabling it, but the loop message keeps appearing.

You try enabling Spanning Tree Protocol on your mesh devices to fix the loop issue. On Omnia it wont help as it would just cut out your LAN0 port

<Off-topic post>

I would suggest to switch the proto from 3G/UMTS to QMI as it can get you faster internet.
Details how to set it up are here: LTE připojení pomocí protokolu QMI [Turris wiki]
It is written in czech but you can just follow the pictures…

</Off-topic post>

1 Like

Thank you very much for this off-topic :wink: