Long message truncated with syslog-ng


I want to use syslog-ng (3.21) to transport suricata messages. They are sometime long, more than 1024 bytes. And they arrive on syslog server truncated at about 1000 bytes. They are also truncated when storing locally.
A “logger” call is also truncated.

I changed the option “log_msg_size” to 4096 in /etc/syslog-ng.conf, but messages are still truncated.

Any idea?