Log flooded with "default route" and " failed to send" messages


My system log is flooded with these messages:

Jul  8 09:43:34 turris odhcpd[3743]: A default route is present but there is no public prefix on guest_turris thus we don't announce a default route!
Jul  8 09:43:34 turris odhcpd[3743]: Failed to send to ff02::1%guest_turris@br-guest-turris (Address not available)

I already read they are basically harmless, but it is very hard to find useful messages in the log.
Is there a way to solve this issue so the messages disappear?
Or disable guest_turris, as I don’t use it, if this will solve these messages appearing.

@Mjanssen You could try two things:

  1. Add manually guest wifi interfaces to br-guest-turris.
  2. Set “bring up empty bridge” in Device configuration for br-guest-turris

Then this should go away :smile:

Thanks for your response.

I checked both settings and both are set as you’ve described.

By manually, you mean through LuCi right? Or another way?

I had the same issue, i think i solved it by SSH on defice and removed the device from either /etc/dhcp or /etc/dhcp-opkg… DHCP is just trying to apply a IP to a disabled guest WIFI.

I’ve found a solution. If you are sure you dont use DHCPv6 then simply disable odhcpd.

/etc/init.d/odhcpd stop
/etc/init.d/odhcpd disable

I agree wholefully. Filtering out / dropping unnecessary noise in logs would definitely be beneficial to anyone, who is trying to find anything useful in logs. Turris support team included :slight_smile:

But this is something that IMHO should be adressed in upstream OpenWrt, rather than in Turris OS.

However, it should be possible to suppress these warnings, even without disabling IPv6 on guest network bridge.

I haven’t tried it myself yet, so just for the reference: A default route is present but there is no public prefix on lan thus we don't announce a default route! - #6 by vgaetera - Installing and Using OpenWrt - OpenWrt Forum