Lighttpd not working with ipv6 disabled in kernel

It is probably not a widespread setup of having ipv6 disabled in the kernel but it however prevents lighttpd from creating sockets, even ipv4 sockets, the way lighttpd is conditioned by default. Subsequent its dependents Foris and LuCI are not available either.

You have to disable ipv6 in lighttpd configuration if you disable it in kernel. Otherwise lighttpd fails to start.

My point was TOS is not checking whether ipv6 is availble (disabled) and not adjusting the lighttpd configuration accordingly.

server.use-ipv6 = "disable" is not getting lighttpd to create a ipv4 socket.
And neither is changing $SERVER["socket"] == "[::]:80" to $SERVER["socket"] == ":80", at least not as long the lighttpd-https-cert is getting loaded with another ipv6 socket [::]:443 conditioned.

In the end removed lighttpd-https-cert and set server.port and server.bind and commented the conditional directive $SERVER["socket"] == in /etc/lighttpd/lighttpd.conf

Because no ipv6 is in reality not supported. You have to do pretty substantial hoop to disable it. There is just no need to have it so that it automatically disabled ipv6 if not provided. Specially when disabling ipv6 is like forcing your self in the past. It’s just not supported and won’t be. If you want it then you are on your own. Of course you can always send patches.