Length of wires running between wireless modules and antennas prohibit swapping them to other slots


#1

Hey everyone,

Brand spanking new owner of the Turris Omnia here: bought it after a few enthusiasts in my surroundings convinced me I could use it to - in time - remove google from my life entirely (which I am very much looking forward to).

As part of the setup I wanted, I needed to build in a mSATA disk. With some help, I found a very helpful video that has been floating around on the fora here, which describes how to install the mSATA disk.

Unfortunately, I couldn’t follow the instructions as provided in this video: apparently the length of the wires running between the wireless modules and the physical antennas have changed. Where the wires in the video were long enough to swap around the modules as suggested, the cables were too short to move any of the wireless modules to any of the other slots than the one in which they were positioned (which matched the starting scenario of the video).

Luckily, the wires can be removed/reconnected without special tools and I noticed that if I would swap the two wires connected to the right antenna (viewing the Omnia with leds facing you, ports at the back), the wires were long enough to move the small wireless module to the left most position as instructed in the video, freeing up the needed mSATA slot.

I just wanted to make the developers of the Omnia aware of this issue and help out any users that bump into the same issue. I am not sure whether this is a “one-of” scenario, but as I typically know manufacturing to be strongly controlled via strict instructions, there might be something else going on here. In any way, I wouldn’t expect a router to be delivered in such a way that swapping the modules around is impossible without doing some “rewiring”.

As stated: the issue has been resolved easily, but I reckoned I’d share my issue and workaround here so it could potentially be fixed during manufacturing or - at the very least - save those who have the same issue some time and/or worries.


#2

I’m facing the same issue and I would love to hear what went wrong.

Since the cables don’t seem to be soldered on, I don’t know if there is a way to fix this ourselves. Anyways I would definitely prefer to get the router replaced with a working product, is there something like a product number that I can pass on to Amazon to guarantee a replacement with the correct cables?

BTW it really scares me that this post didn’t get a reply since January. Is this what I can expect from customer care in the future?


#3

Hey Julian,

If you want to, you can fix it yourself: the connectors for the wires (the ones that rotate freely) can be disconnected and reconnected manually without any tooling required. That is how I fixed it as well.

I do agree with you though that this is an issue that I think will need attention at manufacturing as less tech-savy (or daring) buyers are likely to simply return the router. Let’s hope your repsonse helps to give it a bit more attention :slight_smile:


#4

I assumed that the cables could be switched but hesitated after a gentle pull didn’t do the trick.

I contacted cz.nic directly and got a very fast response, including the attached image. Switching wires 4 and 5 worked but it took quite some force to unplug the connectors.

Thanks for the help!


#5

Many thanks, I also had the same issue. I found that removing the connectors just required a little pull upwards from the cable end.

Subject for another post but I might bin the 2.4/5 GHz duplexors (little boards on antenna connectors 1 and 3) and wire in separate 2.4 GHz antennas.


#6

Technical support is provided on tech.support@turris.cz This is more like a community forum, even though some people on the Turris team typically do read the topics.


#7

FYI: the order of the wifi cards in the image can cause issues: Slow WiFi and bad signal finally solved


#8

This is not what is recommended. See my answer there.


#9

I got the image from the help desk, I’ll send them the link.