LAN ports not working after 1st update after initial setup (auto negotiation failure?)

I set up my Omnia without any problems via LAN4 - plugged it into my FTTP modem after configuring it, WiFi worked, WAN came up - a short while later there was an update which included the kernel and required a reboot. After that my LAN ports don’t seem to be working.

There’s no link light with any of the cables I have here, including the one I initially configured the Omnia with. The Foris UI doesn’t show any link either.

Interestingly, connecting lan4 to lan3 does make carrier show up (link lights go on , /sys/…/carrier goes to 1 for the interfaces in question): So could it be that it’s stopped auto-negotiating?

Followup - looks like maybe it doesn’t like one of my laptops at all, but will give link with another (although again - it worked fine with the one it now hates before the update). More testing to follow. Also the built-in cabling in the house mey be duff, since it never works through the wall rj45 sockets.

Just in case anyone finds this and wonders what the fix was - the in-wall cabling had been miswired, and as near as I can tell this was making something in the hardware-firmware-kernel stack sufficiently unhappy that the ports wouldn’t work once they’d seen a mangled connection.

The Omnia worked fine if it had never seen a mangled connection on that boot (and the cabling has since been fixed).


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.