Kresd writing to disk every 10 minutes

So apparently kresd is writing to the eMMC every 10 minutes, which is far from ideal:

[570377.392886] kresd(20355): dirtied inode 3359031 (data.mdb) on tmpfs
[570377.395009] kresd(20355): dirtied inode 1 (?) on mmcblk0p1
[570377.396884] kresd(20355): dirtied inode 409443 (root.keys.lock) on mmcblk0p1

Due to a bug in init file, kresd is currently restarted every 10 minutes (I’m not certain if every Omnia gets caught into this loop).

Ehm, I guess that fixing the PID file by hand once should work around that cycle, at least until some other reason leads to restarting the service. (Far from ideal workaround.)

Fixing the PID file by hand:

# vi /tmp/run/
If two numbers are present in the file, delete the second one.

Seems to work. watchdog still restarts nethist every 10 minutes, but not kresd.

1 Like

Yes. It’s supposed to contain the PID of the kresd process (a single number). I’m not certain the first one is always the correct one and not the other way around. pidof kresd > /tmp/run/ will most likely work. (Though it’s exactly how the mistake happens, as multiple so-named processes exist during some init actions.)

1 Like

ok that has fixed one issue as it seems, but something else is still writing to disk :stuck_out_tongue: I will investigate further.

@vcunat will this issue be targeted with 3.8.5?

I imagine so, but I’m not on the team myself and thus have no direct information+influence.

1 Like

Fix for this issue is in our repo and will be part of 3.8.5 release (


after this fix, there is still something writing to disk, every 60minutes, far less often than before, but still not “ok” for a eMMC

Right now I’m not able to replicate this. Could you enable block_dump ?
echo 1 > /proc/sys/vm/block_dump

This will log disk writeout to syslog.

cat /tmp/log/messages | grep “debug kernel”

To disable debug
echo 0 > /proc/sys/vm/block_dump

1 Like

I upgraded to 3.8.5 last night, made sure to disable kresd but looking at the system logs, it’s still reactivating itself and intefering with dnsmasq-full.

Is there anyway to disable kresd entirely (stopping short of uninstalling it)? Is anyone else experiecing this as of 3.8.5?

EDIT: For now, I’m resorted to setting a cron job that runs every three minutes to stop kresd when it spawns. So far so good but ultimately, this is just a stop-gap fix until I can find something more concrete.

This is because of watchdog /usr/bin/ (line 32 SERVICES=“resolver”)

1 Like