Kresd blocking reverse DNS from /etc/hosts

I have knot-resolver - 5.1.1-2.0 on TOS 5.0.0
I configured providing DNS for hosts:

list hostname_config '/etc/hosts

while direct resolution works:

gw.lan. 5 IN A 192.168.x.1

reverse does not:

;; AUTHORITY SECTION: 10800 IN	SOA nobody.invalid. 1 3600 1200 604800 10800

explanation.invalid.	10800	IN	TXT	"Blocking is mandated by standards, see references on"

Is this a known bug? Is there something I can do to make resolution working?

Well, yes, this is done sub-optimally right now (upstream link). You can work around it by adding that simple line to your custom configuration.

Thanks, this works. In /etc/default/resolver:

config resolver 'kresd'
        option include_config '/etc/kresd/custom.config'

and in /etc/kresd/custom.config:

policy.add(policy.suffix(policy.PASS, {todname('')}))
policy.add(policy.suffix(policy.PASS, {todname('')}))