Known issues with SDIO Wi-Fi module

It turned out the firmware of the SDIO Wi-Fi module is pretty immature, at least right now. These issues are probably already known to developers but are not documented yet. So let’s list them here:

  • Multiple SSIDs don’t work.
  • WPA-enterprise (802.1x) does not work
  • There are stability issues in 5 GHz band (both with and without radar detection) – the Wi-Fi randomly stops working after few hours. Sometimes it becomes invisible, other times it’s visible but association fails.

From my tests, the Wi-Fi is rock-stable when operated in 2.4 GHz band, with one SSID using WPA2-PSK and CCMP cipher (the default settings).

4 Likes

Do these issues translate over to the Turis? I’ve had to bench mine as the wifi just couldn’t compete with my Old Airport - issues just like those described here. Thanks.

@ Ondrej_Caletka Is there any visibility fo fixes?

This is quite crucial functionality. My MOX is intended to extend coverage of Omnia including the Guest networks.

And also stability of 2.4 is crucial for my backend operations so I preffer not to use buggy module for that. Which means have just one WiFi frequency instead of payed two cause SDIO cannot handle 5.0.

All above are just workarounds, not a functional product.

2 Likes

Good question, but it should be addressed to the Turris team, not me.

I hope they are just software/firmware problems and will be solved eventually.

I know @Ondrej_Caletka :slight_smile:

Btw, I tried your testing scenario above and not so nice on my side. I cannot use the SDIO at all.
Even if I diasamble MOX, reassign everythign carefully and firmly.

I can see both WiFi cards in in Forris and Luci. But the SDIO one is not visible outside. Interesting is that in case SDIO is set to 2.4 it is not even possible to probe it via cmd.

SDIO 2.4, module G 5.0

root@mox:~# iw dev wlan0 info
Interface wlan0
        ifindex 15
        wdev 0x2
        addr 04:f0:21:45:ce:06
        ssid TriStone 5.0
        type AP
        wiphy 0
        channel 36 (5180 MHz), width: 40 MHz, center1: 5190 MHz
        txpower 20.00 dBm
root@mox:~# iw dev wlan1 info
command failed: No such device (-19)

SDIO 5.0, module G 2.4
See the txpower - it is always 0 whatever value is set via GUI or cmd

root@mox:~# iw dev wlan0 info
Interface wlan0
        ifindex 19
        wdev 0x3
        addr 04:f0:21:45:ce:06
        ssid TriStone 2.4
        type AP
        wiphy 0
        channel 1 (2412 MHz), width: 20 MHz, center1: 2412 MHz
        txpower 20.00 dBm
root@mox:~# iw dev wlan1 info
Interface wlan1
        ifindex 21
        wdev 0x100000001
        addr d0:c5:d3:33:ea:93
        type AP
        wiphy 1
        channel 120 (5600 MHz), width: 40 MHz, center1: 5590 MHz
        txpower 0.00 dBm

You may want to contact support about that SDIO-Module, i have sent in one of my moxes because it didn’t detect the SDIO-Module at all.

I am plannig so :wink:

If anyone interested :wink:

Last weekend I did full factory reset (mode 6) because I had also troubles with restart.
Even if I did not set anythign special since first install after this new initialization all problems gone. Restart is smooth and MOX is stable.

And also the WiFi does exactly what described @Ondrej_Caletka at the beginning of the topic. I have two RPI Zero W connected to MOX and they are for whole week rockstable on WiFi and anytime reachable. Which was not the case before reset.

1 Like

Hi,

is there any estimate when the issue with multiple SSIDs will be fixed? Will/can it be fixed at all?

Thanks & kind regards

1 Like

Hi, anything in this regard @Ondrej_Caletka? (highlighting you as you opened up this topic…)

Hi, unfortunatelly this bug nas not been solved yet - from my point of view … Old Turris 1.0 know this perfect, new one (mox) doesn’t work with the same settings…

Yesterday, I’ve had an informal chat with some developers. The Linux driver is actually only a wrapper calling functions of a proprietary firmware, which is most likely the source of all issues. So the developers are more or less locked in by the chipset vendor, who does not participate very nicely.*

Therefore I personally would not expect any improvement any time soon. Should you need a proper working Wi-Fi, I would recommend either another MiniPCIe card within MOX B or MOX G or some proper USB Wi-Fi dongle.

*) I also heard something about a dead horse, although this was probably meant off the record. :wink:

1 Like

Great, I bought Turris MOX Start with SDIO wi-fi module as AP for my Omnia with multiple SSID.

In that case, you can always try to use your warranty. Since this limitation was not documented before and actually is not documented even now, that’s probably the only way forward.

1 Like

In fact that’s what I am strongly thinking of for last month :confused:
Cause the MOX is not able to play the role it was intended (and offered) for. And the future is darker and darker.

1 Like

Any official statement from Turris team?

Sorry for not bringing any news for some time, truth is, we are still investigating and discussing with the supplier and we still don’t know which of the advanced features can be fixed and when.

1 Like

Thanks for the update. Does your discussion with the supplier also, in addition to the problems with multiple SSIDs, cover the stability issues of 5GHz WLAN as mentioned by @Ondrej_Caletka in the first post of this thread?

1 Like

Great question, same interest here. Multiple SSD can be some omitted even if it is painful.

But unstable 5 GHz is deal breaker. And unfortunatelly no also 5 GHz. The solution described by @Ondrej_Caletka and also tested by me was holding for about a month. And the even 2.4 GHz got unstable again.

1 Like