Issues with VLAN Configuration on Turris Omnia (DSA-based)

Hello everyone,

I’m having trouble configuring VLANs on my Turris Omnia (7.1.3 HBS) with Kernel 5.15.148.
My goal is to configure a VLAN on a single port (lan4/trunk) to allow Docker containers (nginx)
to be directly managed by the router (DHCP/DNS) without routing through a QNAP NAS connected to lan4 via Powerline.

But VLAN filtering on single-port bridges fails:
Errors like RTNETLINK answers: Not supported appear when trying to execute bridge vlan add commands manually.
Interfaces like br-l4-vlan or vlan10 fail to come up properly, either through LuCI, /etc/config/network or manual commands.

In the LuCI Network-tab I get an Error like DEVICE_CLAIM_FAILED on Vlan filtered Networks.

ip link shows that VLAN devices (lan4) exist but report NO-CARRIER or state DOWN.
If I manually bring the devices up I cannot reach the Gateway.

Known Background:
Based on research, the issue seems to lie with the current implementation of the Marvell mv88e6xxx DSA driver.

Has anyone had similar issues and found a solution?
What alternative configuration approaches could I try?
Is there an upcoming Kernel update to fix the Marvell mv88e6xxx DSA driver issue?

e.g. config:

config device
	option type 'bridge'
	option name 'br-vlan'
	list ports 'lan4'
	option vlan_filtering '1'

config bridge-vlan
	option device 'br-vlan'
	option vlan '10'
	list ports 'lan4:t'
	
config interface 'vlan10'
	option device 'br-vlan.10'
	option proto 'static'
	option ipaddr '192.168.10.1'
	option netmask '255.255.255.0'

best regards,
Lukas

PS: I could successfully connect my lxc-container from Turris to a VLan, but not one of the physical-ports.

If you create new bridge make sure lan4 is not part of standard br-lan