Is my radio stuck on Chl 36 (5GHz) [Solved]

Hi - I’ve got a weird (user?!) issue manually setting a preferred wifi channel for 5GHz via the web interface(s).
If I change the setting from the default(36) to anything else the interface goes down and won’t re-enable.
Rebooting with the config saved brings the interface back up but still stuck on Chl36 - any ideas?


Have you tried to change the channel in the config file /etc/config/wireless ?

@Codetux Thanks for the tip, oddly Luci and the basic admin pages show 40 but the wireless config is still 36… Apart from feeling like a total noob (I’ve used openwrt extensively believe it or not) any ideas why the admin page and the config files aren’t in sync?


make sure after you make a change in /etc/config/wireless that you run uci commit wireless

@Jason_A - thanks maybe I had a duff page cached in the browser or something, just used Foris to update again and it’s fine…


Ok - so I spoke too soon… I really am stuck on channel 36 and can’t seem to change it:

wireless in /etc/config:

config wifi-device 'radio0’
option type 'mac80211’
option country 'CZ’
option hwmode '11a’
option path 'platform/soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0’
option htmode 'VHT80’
option txpower '23’
option channel ‘40’

wlan0 ESSID: "Turris"
Access Point:
Mode: Master Channel: 36 (5.180 GHz)
Tx-Power: 23 dBm Link Quality: unknown/70
Signal: unknown Noise: -100 dBm
Bit Rate: unknown
Encryption: WPA2 PSK (TKIP, CCMP)
Type: nl80211 HW Mode(s): 802.11bgnac
Hardware: 168C:003C 0000:0000 [Qualcomm Atheros QCA9880]
TX power offset: none
Frequency offset: none
Supports VAPs: yes PHY name: phy0

When I try to change it manually: iw wlan0 set channel 40
command failed: Resource busy (-16)

Any other ideas?

Fixed - factory reset / reinstall seems to have resolved it. Now working as expected…