Ipv6: wan6 ok, lan stopped

Hello,
need help with my Turris Omnia ipv6 configuration.

Last week, my devices stopped working over ipv6 (i think after an ISP-Modem or TO update).
I resetted modem and TO, configured, rolled back, nothing helped.
No device behind TO gets an public ipv6 address. TO wan6 seems ok, ping6 ipv6.google.com works fine.

Combinations:

  • Works: Modem <> Devices
  • Works: Modem <> AVM Repeater <> Devices
  • Fails: Modem <> TO <> Devices

_

ifconfig output:

eth2
Link encap:Ethernet HWaddr D8:58:D7:XX:XX:XX
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: 2a02:8388:701:b980:xxxx:xxxx:xxxx:xxxx/64 Scope:Global
inet6 addr: fe80::da58:d7ff:fe00:3bda/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:24311 errors:0 dropped:0 overruns:0 frame:0
TX packets:23199 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:532
RX bytes:9314532 (8.8 MiB) TX bytes:5208100 (4.9 MiB)
Interrupt:39

br-lan
Link encap:Ethernet HWaddr D8:58:D7:XX:XX:XX
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fdc9:69:69:1::1/64 Scope:Global
inet6 addr: fe80::da58:d7ff:fe00:3bd9/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:734 errors:0 dropped:0 overruns:0 frame:0
TX packets:347 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:44382 (43.3 KiB) TX bytes:120607 (117.7 KiB)

ifstatus wan6:

{
“up”: true,
“pending”: false,
“available”: true,
“autostart”: true,
“dynamic”: false,
“uptime”: 95,
“l3_device”: “eth2”,
“proto”: “dhcpv6”,
“device”: “eth2”,
“metric”: 0,
“dns_metric”: 0,
“delegation”: true,
“ipv4-address”: [

    ],
    "ipv6-address": [
            {
                    "address": "2a02:8388:701:b980:xxxx:xxxx:xxxx:xxxx",
                    "mask": 64,
                    "preferred": 604797,
                    "valid": 1209597
            }
    ],
    "ipv6-prefix": [

    ],
    "ipv6-prefix-assignment": [

    ],
    "route": [
            {
                    "target": "2a02:8388:701:b980::",
                    "mask": 64,
                    "nexthop": "::",
                    "metric": 256,
                    "valid": 1209597,
                    "source": "::/0"
            },
            {
                    "target": "2a02:8388:701:b980::",
                    "mask": 57,
                    "nexthop": "fe80::aef8:ccff:fe1e:3985",
                    "metric": 512,
                    "valid": 1209597,
                    "source": "2a02:8388:701:b980:xxxx:xxxx:xxxx:xxxx/64"
            },
            {
                    "target": "::",
                    "mask": 0,
                    "nexthop": "fe80::aef8:ccff:fe1e:3985",
                    "metric": 512,
                    "valid": 1797,
                    "source": "2a02:8388:701:b980:xxxx:xxxx:xxxx:xxxx/64"
            }
    ],
    "dns-server": [
            "2a02:8383:d:c::1",
            "2a02:8383:d:c::1000"
    ],
    "dns-search": [

    ],
    "neighbors": [

    ],
    "inactive": {
            "ipv4-address": [

            ],
            "ipv6-address": [

            ],
            "route": [

            ],
            "dns-server": [

            ],
            "dns-search": [

            ],
            "neighbors": [

            ]
    },
    "data": {
            "passthru": "001700202a028383000d000c00000000000000012a028383000d000c0000000000001000"
    }

}

ifstatus lan:

{
“up”: true,
“pending”: false,
“available”: true,
“autostart”: true,
“dynamic”: false,
“uptime”: 161,
“l3_device”: “br-lan”,
“proto”: “static”,
“device”: “br-lan”,
“updated”: [
“addresses”
],
“metric”: 0,
“dns_metric”: 0,
“delegation”: true,
“ipv4-address”: [
{
“address”: “192.168.1.1”,
“mask”: 24
}
],
“ipv6-address”: [

    ],
    "ipv6-prefix": [

    ],
    "ipv6-prefix-assignment": [
            {
                    "address": "fdc9:69:69:1::",
                    "mask": 64,
                    "local-address": {
                            "address": "fdc9:69:69:1::1",
                            "mask": 64
                    }
            }
    ],
    "route": [

    ],
    "dns-server": [

    ],
    "dns-search": [

    ],
    "neighbors": [

    ],
    "inactive": {
            "ipv4-address": [

            ],
            "ipv6-address": [

            ],
            "route": [

            ],
            "dns-server": [

            ],
            "dns-search": [

            ],
            "neighbors": [

            ]
    },
    "data": {

    }

}

uci show network:

network.loopback=interface
network.loopback.ifname=‘lo’
network.loopback.proto=‘static’
network.loopback.ipaddr=‘127.0.0.1’
network.loopback.netmask=‘255.0.0.0’
network.globals=globals
network.globals.ula_prefix=‘fdc9:69:69::/48’
network.lan=interface
network.lan.type=‘bridge’
network.lan.proto=‘static’
network.lan.ipaddr=‘192.168.1.1’
network.lan.netmask=‘255.255.255.0’
network.lan.bridge_empty=‘1’
network.lan.ifname=‘lan0’ ‘lan1’ ‘lan2’ ‘lan3’ ‘lan4’
network.lan._turris_mode=‘managed’
network.lan.ip6assign=‘64’
network.wan=interface
network.wan.ifname=‘eth2’
network.wan.proto=‘static’
network.wan.netmask=‘255.255.255.0’
network.wan.gateway=‘192.168.0.1’
network.wan.ipaddr=‘192.168.0.2’
network.wan.ipv6=‘1’
network.wan.dns=‘1.1.1.1’ ‘9.9.9.9’
network.guest_turris=interface
network.guest_turris.type=‘bridge’
network.guest_turris.proto=‘static’
network.guest_turris.ipaddr=‘10.111.222.1’
network.guest_turris.netmask=‘255.255.255.0’
network.guest_turris.bridge_empty=‘1’
network.guest_turris.dns=‘192.168.1.4’
network.guest_turris.enabled=‘0’
network.guest_turris.ip6assign=‘64’
network.wan6=interface
network.wan6.ifname=’@wan
network.wan6.proto=‘dhcpv6’
network.wan6.reqprefix=‘auto’
network.wan6.reqaddress=‘try’
network.vpn_turris=interface
network.vpn_turris.enabled=‘1’
network.vpn_turris.ifname=‘tun_turris’
network.vpn_turris.proto=‘none’
network.vpn_turris.auto=‘1’

Other infos:

ISP:

magenta.at (cable)
DS-Lite
Modem DHCPv6 server:

Any solutions?
Thanks in advance

Since this is obviously DOCSIS, blame the cable modem. Most of them are super crappy and either don’t do DHCPv6-PD at all or can delegate only to one device. If it worked before, try doing a factory reset of the cable modem. Hopefully it will be able to delegate the one prefix again.

1 Like

What is the size of the prefix delegated to you with DHCPv6-PD? In case it is /64 only, you can try to enable the NDP proxy on your Turris Omnia.

I have no idea, I configured ipv6 manually before that happened.
I’ll keep trying.

Thanks

Added / Changed these lines and now it works again.

/etc/config/dhcp:

config dhcp ‘lan’
option dhcpv6 ‘relay’
option ra ‘relay’
option ndp ‘relay’

config dhcp ‘wan6’
option dhcpv6 ‘relay’
option ra ‘relay’
option ndp ‘relay’
option master ‘1’
option interface ‘wan6’

Screenshots

Screenshot_20220302_131005