IPv6 static route not loaded after reboot

I have added static routes both for IPv4 and IPv6. With IPv4 it works. For IPv6 it works but when I reboot the router the route is not loaded.

When I check /etc/config/network I find the route:

config route6
option interface 'lan’
option target 'fdc2:xxxx:xxxx:xxxx::/64’
option gateway ‘fdc2:xxxx:xxxx:xxxx:yyyy:yyyy:yyyy:yyyy’

Also when I load the route manually it works:

ip route add fdc2:xxxx:xxxx:xxxx::/64 via fdc2:xxxx:xxxx:xxxx:yyyy:yyyy:yyyy:yyyy dev br-lan

What can be the reason why this route is not loaded after starting the router?

Strange: today after the boot of the router it worked.

Don’t understand what is going on: just checked for the route. I can see in /etc/config/network and in the GUI but on the system the route is not set.

After clicking Network -> Static Rules -> Safe & Apply the route appears on the system.

After reboot the route is still in the configuration but not set.

I have now put a command to set this route into /etc/rc.local.

But I consider this not as solution. This is a workaround.

Did you have any errors in the logs?

There is a lot of stuff in there but nothing that gives me a clue that the system tried to set this route.

For example I find this traceback:

2016-12-26T18:40:57+01:00 debug updater[2712]: src/lib/locks.c:44 (lua_acquire): Trying to get a lock at //var/lock/opkg.lock
2016-12-26T18:40:57+01:00 debug updater[2712]: backend.lua:347 (status_parse): Parsing status file /usr/lib/opkg/status
2016-12-26T18:40:57+01:00 debug updater[2712]: src/lib/journal.c:123 (journal_open): Opening journal
2016-12-26T18:40:57+01:00 emerg sfpswitch.py[1599]: line not found
2016-12-26T18:40:57+01:00 debug updater[2712]: src/lib/interpreter.c:105 (interpreter_error_result): ^M
Stack Traceback

(2) Lua function ‘?’ at line 64 of chunk ‘“logging”]’^M
Local variables:^M
err = string: “[string “transaction”]:351: No journal to recover”^M
err2string = Lua function ‘?’ (defined at line 45 of chunk “logging”])^M
msg = string: “
[string “transaction”]:351: No journal to recover”^M
(*temporary) = table: 0x7ff670 {msg:
[string “transaction”]:351: No journal to recover}^M
(3) C function ‘function: 0x69c970’^M
(4) field C function ‘recover’^M
(5) Lua global ‘recover’ at line 351 of chunk ‘“transaction”]’^M
Local variables:^M
run_state = table: 0x6b46f0 {initialized:true, init:function: 0x6b4720, lfile:userdata: 0x6ce348, release:function: 0x687340 (more…)}^M
(6) Lua function ‘?’ at line 412 of chunk ‘“transaction”]’^M
Local variables:^M
(*temporary) = Lua function ‘?’ (defined at line 378 of chunk “transaction”])^M
2016-12-26T18:40:57+01:00 crit updater[2712]: src/opkg-trans/main.c:102 (main):
[string “transaction”]:351: No journal to recover
2016-12-26T18:40:57+01:00 emerg sfpswitch.py[1599]: ^[[31;1mDIE^[[0m:
2016-12-26T18:40:57+01:00 emerg sfpswitch.py[1599]: [string “transaction”]:351: No journal to recover
2016-12-26T18:40:57+01:00 emerg sfpswitch.py[1599]: Aborted