IPv6 DNS server automatic configuration

I’m playing with IPv6 configuration on TO and run into the following strange behaviour:

  • both cable and wireless connections are part of default br-lan interface
  • I want to provide access to KnotDNS running on TO throug ULA addresss. The configuration of br-lan interface is:
option ip6assign '64'
option ip6hint '1'
list dns 'fdxx:xxxx:xxxx:3::1'
list dns_search 'home'
  • I’m running both IPv4 and IPv6 on the interface

  • the client is Windows 10 notebook

  • when I enable RA-service only (server mode) and the notebook is connected over ethernet cable then it is configured as I’d expect:

   DNS Servers . . . . . . . . . . . : fdxx:xxxx:xxxx:3::1
   Connection-specific DNS Suffix Search List :
  • However when I connect over Wifi I can see only the IPv4 address of DNS server and IPv6 is missing
  • When I enable also DHCPv6 (sever mode) then the DNS settings on the Wi-FI is as above (correct) but when I connect over cable the configuration is doubled
   DNS Servers . . . . . . . . . . . : fdxx:xxxx:xxxx:3::1
   Connection-specific DNS Suffix Search List :
  • when I read about IPv6 the duplication is correct as the client should merge data coming through rotuer announcement and DHCPv6 but I’m struggling to find out why the connection over wifi doesn’t respect the RA about DNS when it respects the prefix announcement.

I tested it on 2 different win10 machines with the same behaviour so it doesn’t seem to be client/notebook configuration specific.
Any hint on what could cause the different behaviour?

From what I know the IPv6 has doubled the IP addreses because some are link only.

You could verify by looking at the ’ip addr’ comand and looking at the br-lan interface.

There should be IPv6 address scope global and one scope link only.

And thats expected.

Now I’ve reread your post and it is not the case in your setup. Its literally double time the same address.