IPV6 cable modem issues

Hello there, today my cable modem & ISP provider activated IPV6. The cable modem is in bridge mode.
Great, so i activated ipv6 in reForis. i used the DHCPv6 option, and since i am a nOOb, i put this on auto…
Now…all seems to work well to the outside. all connections work, streaming , torrents, everything…

BUT. now, my cable modem has the adress ( or even ) . When i reboot the omnia, i get a DHCP adress from the modem on ipv4. it is 88.89.xx.xx , my ext ip is xx3.xx.xx.xx. according to ip lookup. And now i cant reach the cable modem anymore… says no ping.

So as soon as this is active : Protocol: Dual-Stack Lite (RFC6333)

I cant reach my cable modem anymore. No clue why, but i suspect it has something to do with that dual stack thingie…

ok, solved it. shouldertap, no clue. I will leave it on the forum, so others might find it helpfull?

the default gateway option was the trick. unselect both WAN and WAN6 default gateway X , select the WAN, and after select WAN6 default gateway. that solved the IP4 gateway connectivity issue. And so modem is reachable.

well, all is not well yet…if i reboot, i have to do this again… does someone know here if you have to make just one ( ip4 or ipv 6 ) the default gateway ?

That is DS-Lite.
You can add option iface_dslite '0' to your wan6 interface under /etc/config/network to don’t have it auto created.

yep, that is automagic starting after 20 seconds. The problem is though that if i reboot the router, i have to manually de-select and select the option default gateway in the IP4 WAN section, see picture

Otherwise my ip4 gateway does not work. Don’t know if this is a bug, but it sure looks like something is less optimal with this type of auto-config.

But after i only de- and select that option all is fine… So, do i need it? That is more the question, since i found out that the cable network is actually using this type of connection?

Instead of using the builtin IPv6-managment, try creating separate WAN and WAN6 interfaces, each of which obtains their IP addresses via DHCP/DHCPv6:

config interface 'wan'
        option device 'eth2'
        option proto 'dhcp'
        option delegate '0'

config interface 'wan6'
        option device 'eth2'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix '56'
        option iface_dslite '0'

To reach the modem in bridge mode, you can add another static IP address to your WAN interface:

config interface 'modem'
        option device 'eth2'
        option proto 'static'
        option ipaddr ''
        option netmask ''

Add all of the above to the WAN firewall zone, and you should be set.

1 Like

Ha, thxs! yep, i will try that tomorrow… just small question about the req prefix in wan6 , i think i’ve read that it should be 57 instead of 56? Nou clue, but current one has 57?

this is the current one on wan6 IPv6-PD: xxx:xx0:xx:dd00::/57

Looks like Ziggo in the Netherlands? After the IPv6 introduction my connection stalled frequently. Not knowing enough about this low level networking I disabled IPv6 on the router. Please share the final solution! It seems to matter whether you are located in the “old UPC” area (most of Amsterdam, I think) or elsewhere.


If your ISP assigns a ::/57, use that, or even a ::/60 (still good for 16 internal subnets).

1 Like

If you want to reach the modem, create a new virtual interface assigned to eth2 (similar as is with WAN6 interface) and assign it a static address in the range. Add it to the WAN firewall zone and then you will be able to reach the modem with its address

Like this.

1 Like

Tried it, but without the DSlite ipv6 does not work to the outside.

apperantly this ISP ( ziggo /upc klopt Jan, UB13 kabelmodem ) ) needs the Ds lite.

So back to the config you suggested without the DS lite '0" line, ipv6 works. Ip4 gateway only works after i manually de mark and mark the default gateway option in the ip4 config?

With Ziggo, you may want to try the instructions from the OpenWRT documentation. I am with a different ISP, and therefore cannot verify this.

Well, last night the ISP did something with the network, and If i reboot the router, all is fine now.

Both ip4 and IPV6 work. Hurray!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.