Internet access problem with TC4400 modem

i removed my old NAT-operated FritzBox and replaced it by a Technicolor TC4400 DOCSIS modem.
Modem is setup with DualStack (according to the cable network operator). However, there are major problems during initial start-up. After Factory Rest my Turris Omia only runs up to level 3 (Connectivity check) and hangs in a loop. After manual configuration the WAN Connectivity test shows only IP6 and not IP4. But in Luci IP4 is displayed correctly configured and the connection works.
If I configure IP6 via Luci no DNS works anymore. Does anyone know the configuration TC4400 / Turris Omni and can help?
Regards Harald

Hello Harald,
i have the same configuration at my site, using the Turris Omnia together with a TC4400 Modem.
I used the luci-Webinterface you simply set both interfaces WAN and WAN6 to DHCP.

Remember that you have to tell your provider the usage of the device.
If you still have DS-Lite activated and Dual Stack is not yet in use you wont get a IPV4 address.
You can see this beneath your IPv4 adress on the WAN interface via the Default overview page.

Best regards,


Hello Georg,
thank You for Your reply and the status of Your configuration. I did the same but I get either IP4 or IP6 connectivity but not both together. I disabled wan6 and IP4 operation works fine.
Please can You give me some information about Your luci interfaces configuration.
I configured:


Did You also connect eth1 to the wan interface and “wan6” to wan6 interface? I tried almost all cominations but none of them was successful.

Hopefully I can get some hints to solve this problem.

Best regards

I changed the WAN6 interface from the obscure Interface @wan6 to eth1 as it should use the physical interface and no “not existent” one. That way both IP Protocols gather their IP Adress via DCHP and via the Modem…

Can you give an example what /etc/config/network should look like for both wan and wan6 in this case?

My /etc/config/network file:

config interface ‘wan’
option ifname ‘eth1’
option proto ‘dhcp’
option ipv6 ‘1’

config interface ‘wan6’
option proto ‘dhcpv6’
option _orig_ifname ‘eth1’
option _orig_bridge ‘false’
option ifname ‘eth1’
option reqaddress ‘try’
option reqprefix ‘auto’

after the change dont forget to restart the network interface by running ‘$ /etc/init.d/network restart’
After this settings you get an IPv4 and V6 address

I think I solved the problem. My cable network provider (unitymedia in Germany) confirmed a dualstack configuration what means that both, IPv4 and IPv6, should be parallel available.
I read a problem report in a openwrt/lede forum that in some cases a native IP4 address is provided by the operator and also a ds-lite configuration is sent to the modem (caused by AFTR option reveived by DHCPv6 server). This caused trouble in the TC4400 modem and/or in the turris router.
Checking turrris with ifconfig I realized that I had a ds-wan6_4 interface (ds-lite!), although I had real dualstack. The solution was to insert a line in /etc/config/network (in the wan6 network config section): option iface_dslite ‘0’
This disables the ds-lite configuration and finally solved the problem to operate a stable dual-stack.


Thanks for the hint!

I can reproduce this behaviour with ISP Unitymedia (DualStack) using their Connectbox in Bridge Mode and Turris Omnia with Turris OS 3.11.6.

Your solution worked :+1:t3: