Intermittent repeated loss of Internet connectivity

Hi. I’m new here; as needed, please point me towards the appropriate n00b tutorial/resource/RTFM links first.

I have a Turris Omnia, (from the original Indiegogo fundraiser, though I only started using it 4 years ago). I also have a Turris MOX, with separate (?) issues; get to that later, probably in a separate thread.

I have been having sneaky intermittent “the Internet is broken again, no It’s back, no It’s broken again” issues for 2-3 years, across two different ISPs and countries (UPC in Hungary, and Ziggo here in The Netherlands), which I’m now pretty sure stem from the TO.

It mostly works fine, most of the time, and then someone on the LAN starts doing something on one machine that causes everyone to lose Internet access for 2-3 minutes, then access returns for 1-15 minutes, then gone again, up and down, sometimes for hours.

I’ve pinned down a few specific things that fairly consistently cause the issue (my girlfriend using her laptop for youtube and/or networked game-related activities, me downloading media with a BitTorrent client) … but it’s never a clear, 100%, “okay, this is the problem” cause.

We did discover that if my girlfriend accessed her youtube and gaming stuff through a VPN, the problem mostly went away (though there were–and are–other intermittent things, which we’ve mostly been unable to ID, which still trigger the problem).

About 6 months ago, Ziggo ISP or TurrisOS pushed some kind of upgrade that completely broke our Internet access, and after a couple days of back-and-forth with the ISP, I discovered on my own, that the problem was that the cz.nic DNS provider no longer worked thru my TO. I have no idea why that would suddenly become an issue (I used cz.nic exclusively, up to that point) … however, once I discovered and switched over to Quad9, everything was better (and to this day, the cz.nic DNS setting breaks our Internet … why?).

We never fully identified nor resolved the intermittent connectivity issue, though, despite multiple service calls to both ISPs.

And then, last week, I finally pulled the trigger on the major 3.x-to-5.x upgrade … and that has made the problem much worse. VPN no longer circumvents the issue, and now, both the girlfriend’s laptop and mobile phone trigger it nightly, and BitTorrent is almost useless (downloading, eg, a 20GB file, will actively download 5-20 MB in 10-15 seconds, then the Internet is broken for everyone for 3-5 minutes, then reconnect, download 5-20 MB more, and etc).

The girlfriend’s computer is a Win10 machine, phone is Android … but we have 2 other WinDoze boxes on the LAN, 2-4 other Android devices, plus a half-dozen Linux boxes of various flavors, and even an Apple tablet, and given the right phase of the moon, any one of them can trigger the issue.

I’m fairly comfortable in the terminal, and with ssh. Most of my machines are Linux, and I’m not afraid of getting into the guts of them. OTOH, I have never done any kind of command-line management of my routers, just the GUI admin tools, and I have very little knowledge of what is going on “under the hood”, beyond a generalized understanding that “it’s Linux-ish”.

I did see one other active “help” thread here that sounded potentially similar to my issue – Omnia drops a lot of packets over ethernet … maybe the same, maybe not.

So … you know … what do I do?

Danke, y gracias

ETA: Earlier today, I assigned a static leased IP to the girlfriend’s laptop. Tentatively, that appears to have helped … but, early days.

Ive also been experiencing some issues lately. Im Dutch and I also have Ziggo as ISP.

Here are my symptoms;

  • So now and then internet connectivity breaks. Then the router restarts. But it doesnt fulfill the restart cycle to the end. Only white lights on the TO.
  • I have to manually restart it, and pull the WAN wire out, or else I dont have an internet connection
  • With the WAN cable out, TO does a complete restart cycle (And the leds go to the colour that ive programmed)

Then its good for some days, until it happens again.

It worked rather nicely until recent updates.

I’m in the US with an Omnia purchased off of Amazon. I had constant problems of being connected to the router (via Wi-Fi) with no Internet access on multiple devices. I ended up disabling the internal Wi-Fi cards on the omnia and using external APs for wireless. I hated doing this on such an expensive router but everything has worked perfectly since this change.

Are you running your Ziggo modem/gateway thing in pass-through mode? You have to call them and have a technician “flip a switch” at their headquarters before you can use this mode … and, you also need to call them when you want it turned back off.

I am running it in pass-through mode, giving my TO full router responsibilities. Regular Ziggo gateway operation == solid white display light. Pass-through Ziggo operation == solid green display light.

Until this latest round of TO OS updates, we could always ID the problem as, ultimately, the Ziggo modem rebooting itself. However, this past week, the Ziggo modem is rock-steady during our intermittent Internet outages.

At this point, and barring any useful feedback from the Turris folk, I’m inclined to get Ziggo to switch their gateway back to normal router mode, and just run an alternate/adjunct subnet off of it with the TO. Current situation is untenable.

Regarding the ”flapping” internet access issue.
This smells like a perfect match for bad ethernet cable(s)

Easiest solution:
replace ALL cables in you network to new factory pressed (i.e. Do not press connectors your self)

More timme consuming:
Check Omnia logs for interfaces going up and down and for packet drops/ retransmissions.
Wan side/lan side/ which ports.

You may find mtr a useful tool from a client connected to the omnia.
For example:
$ mrt
and watch the output when you access to internet drops out.

Good tip, but checked that already. Only one cable to check in my situation – the one between my TO and the Ziggo gateway/modem. Most of the other machines are on WiFi.

And do not cheat, don’t check - buy new ones :slight_smile:

Can that explain why a video stream (~6Mbps) drops out and an audio stream (~192Kbps) doesnt?

If the cable is faulty, shouldnt all connections drop out? TBF, its a new cable, and when placing it I thoroughly searched for things that might cause a problem in the future. Couldnt find one.

And a reboot solves it everytime, but if you still think its a problem I can replace the cable. I just dont see symptoms that imply cable failure.

Devil’s Advocate for @tac2 … there’s an awful lot of buffering going on in streaming stuff … you can lose Internet for several minutes w/o noticing because the service downloaded 5+ minutes’ worth of media in advance, while a different service only downloaded 30 seconds’ worth, and etc.

1 Like

Now - there are many different issues described by different persons in this topic.

But in general I suggest start trouble shooting at the lowest possible level.
I.e. remove applications/wifi/ and other moving parts from the equation.

  1. Check for flapping wan link
    You turris os logs will help you
  2. Check flapping upstream router/gateway
    Ping/mtr or other tool directly from router
  3. Hook up a known good computer to you router with wire and run it for days/weeks depending on how often you experience issues

when you have a known good state of the basics, wired internet connection. You can start higher upp.

So please do not add other random issues in this topic

@nattiegoogie you never know what ISPs are doing with dns traffic, some even try to block you from using external forwarders.others brake dnssec, which you omnia don’t like

1 Like

I see a lot of failed login attemps trying to login into ssh and openvpn. Mitigated for now. Lets see how that goes.

Hi there,what type of cable modem did your ISP gave you, a connectbox maybe?

Since i do recognize the problems, and with that specific Provider the TO was not the issue, the actual cable modem was. If you have a ( white ) ‘connectbox’ ( with a Puma 6 chip ) and you run a VPN and/or Torrents the modem goes random totally bananas. Connection drops random etc etc.

You need to get the Ubee UBC1318ZG modem, that will solve the disconnects? Check the forum from the ISP Opgelost: Re: Downloadsnelheid erg laag met VPN en torrents - Pagina 23 - Ziggo Community


Yes I have connectbox, but i rarely use torrents.

After shutting off OpenVPN and HaaS, no more problems. Cant say “Yay” tho :frowning:

The connectbox is famous for having problems with VPN. Contact ISP ( Ziggo ) on the forum, and they will send you a Ubee 1318. I had the same issues, changed modem, problems gone.
No difference in use, you can also put it yourself in bridgemode.