Intermittent internet through 5GHz wifi


#1

Hello!

I’ve had this problem for quite some time, but I’m finally getting around to asking for help on it because it’s going to cause me to replace my omnia if it keeps up.

The problem is that on wifi the router frequently fails to provide functional access to the internet. You’ll be using it then all of the sudden webpages will fail to load, services will fail to respond. Switching to my 2.4ghz channel, which is provided by an Apple Time Capsule via one of the Omnia’s ethernet ports yields full function. It’s worth noting there are never any issues when using the wired connections, this is a problem specific to the Omnia’s wifi. I now realize that the 2.4ghz issues I was having that caused me to switch to the time capsule in the first place were likely symptomatic of this same issue.

When the 5ghz connection works it’s fast and stable. It’s a very on/off type thing. It either works completely or it doesn’t at all. It’s worth noting that the client always appears to stay connected, there is just a failure to serve data through the connection.


#2

What chanel 5 Ghz ? Lower channel or higher with DFS ?

WIFI 5Ghz si connected or broken (disconnected) … when fail internet connection ?

The problem is with one or more 5 GHz devices ?

Bez názvu


#3

No broken connection, and channel does not seem to matter. Thanks for your help!


#4

If you have a channel …DFS. setting, there may be a frequency collision with a meteorological radars and router automatic frequency changing. This causes up to 15 minutes to disconnection

How long does it take to disconnect? will he proceed to self-renewal?


#5

I’ve seen similar annoying effects. The wifi connection itself is established, signal is ok, but the transmission is not possible at first. For me it mainly affects mobile devices with iOS. Interestingly, the webpage “www.wikipedia.org” works via mobile browser. Not really explainable! Can you please also test whether this is also the case with you.

Which operating systems does this affect for you?

Please try the following:

a) Can you still reach the gateway with the client (ping to the router)
b) Does the DNS resolver work? (ping a public website)

Guess it’s more of a resolver problem. But the logs haven’t helped me yet. Unfortunately, I don’t have time for the Wireshark…


#6

For me it happens regardless of client. Laptops, mobile, doesn’t matter from what I’ve seen. Everything wired always works.

There is no interval from what I can see. It’ll work perfectly for hours or days then suddenly fail completely. Sometimes switching off and then back fixes it, but not always.

I don’t recall it ever happening for local servers, and I run one I’m on often, but I can’t say for sure it doesn’t do it. I’ll have to check pings and resolving next time it happens to a laptop. It seems to afflict mobile clients more.


#7

How long does the downtime usually last? is the set WiFi channel Spontaneously changing?


#8

I haven’t seen the Wifi channel change, but I will keep an eye on that. It’s hard to guesstimate how long the downtime lasts, because I usually run out of patience and switch to the 2.4GHz band broadcast by the Time Capsule before it starts working again. I haven’t been able to find evidence in the logs that consistently correlates with this problem, which is really frustrating.


#9

Could you first give the output of this…

cat /etc/turris-version

Secondly, could you give the output of this. REMOVE YOUR WIFI SETTINGS part (Option key + option ssid + identity …etc. etc. ) BEFORE posting.

cat /etc/config/wireless

Also could you post the results of this.

iw reg get

And not to forget the results of this, ASSUMING your 5 Ghz is wlan0

iwlist wlan0 scan | grep Frequency | sort | uniq -c | sort -n

#10

Hello Big_boss,

Sorry for the delay in responding, I had some personal issues pop up and wound up just getting a Ubiquiti AC-Pro to handle the wireless and leave the wired and routing/nat duties to the Turris because I wasn’t going to have time to troubleshoot. I thought I had responded but realized I must not have submitted it. Thanks for your assistance.


#11

I’ve been having the same problem my MacBook Air. Tried everything from adjusting the radio channels to starting all over at factory settings. Nothing that helped stuck. Until now…

I’ve dialed the 5Ghz channel up above the frey to 149 and, finally conformming to prevailing wisdom, bestowed both the 2.4GHz and 5Ghz radios the same SSID. Presumably, when my MacBook loses its way, it will quickly regain its composure on the other band.

There haven’t been any freeze ups since. Fate, now tempted, may have other plans. We shall see.

Cheers!


#12

I had read your comment, but had no time to respond. I can’t read your old comment again, but whatever you do, try to PREVENT using the DFS channels. I myself am using channel 36 and experience no problems.

In one of the comments you could indeed clearly see channel 48 being used by many. But also with this, i can’t see the iw reg get output of US, to see if channel 48 was a DFS channel. DFS channel is a channel that is being used by weathersatellites. So if one flies by, your omnia will change channels.

In my case it went to a channel which my clients did not support. So the result being no connection between my Omnia and the client (be it, Chromecast, Smartphone or whatever).

Also a tip as 5 GHz doesn’t get inteferred that much by even neighbors (because of range), i would say put it in a place that you can broadcast through the whole house/appartment. I live in a appartment without staircases, so all the rooms are on the same floor. Try to play with the antennas (Horizontal, semi-horizontal-vertical, vertical). The position of the antenna can change a lot. Try to also think about amount of obstacles between the Omnia and your clients. These are just some tips, if you still experience some problems, do let me know.


#13

Hi Rhynri,

Bro, no offence, but that is not really a solution. I have noticed that many “problems” are rather little piece of knowledge that i did not know. By tweaking and changing this and that, everything will work optimal.

If you find the time and are willing to find the cause of your problem, do let me or any other member know.


#14

I’d agree in that all problems are lack of knowledge of solutions.

However, for the cost of my time this is a perfectly workable solution. Ubiquiti’s AP much more closely meets my wireless needs than the Omnia could, thanks to their controller software. I’ve also retired the Omnia from NAS duties, instead delegating them to my unRAID server. I really enjoy having the Omnia as a dedicated wired only router, so much so I may wind up replacing it with a Turris MOX for the expanded Ethernet port support, but that’s neither here nor there.

The omnia is an excellent device, and I don’t hold any ill will towards Turris on account of my issue.


#15

Well if one asked me from the beginning for having the Omnia as a NAS device, i would not be such a great fan of it anyways. Often having two separate things, is not only more stable, but performance-wise is a MUCH better and wiser solution.

About the Omnia itself, maybe it is as you point out (lack of knowledge of solutions), but if you would only spend some time knowing what it is capable of, you would not easily brush it aside, believe me. About valuable time, this i have often heard A LOT by many people…time after time, while in the mean time, they spend more than enough time browsing Facebook like a zombie, or watching tv like a zombie, or watching useless movies, series, watching late-night nonsense…and what have you. I am not saying you are doing that, but just putting things in perspective.

We indeed must make a choice in spending our time, but we really have to take some time and question our “valuable” time that often is spend on the most rubbish things out there…whatever it maybe. Anyways, thanks for reading my rant :P. As you were soldier XD.

Forum is always open if you change your mind ;).


#16

Thanks for your reply.

Regarding DFS, the Wikipedia List of WLAN Channels page, here in the US channel 149 lies just north of the DFS block. I’ll see how long this solution holds out before dialing back down to the 36 - 48 range.

Here are the outputs of my config as they stand now:

root@turris:~# cat /etc/turris-version
3.9.6
root@turris:~# cat /etc/config/wireless

config wifi-device 'radio0’
option type 'mac80211’
option hwmode '11a’
option path 'soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0’
option htmode 'VHT80’
option disabled '0’
option txpower '23’
option country 'US’
option channel ‘149’

config wifi-iface
option device 'radio0’
option network 'lan’
option mode 'ap’
option disabled '0’
option key 'xxxxx’
option ssid 'yyyyy’
option encryption ‘psk2+ccmp’

config wifi-device 'radio1’
option type 'mac80211’
option channel '11’
option hwmode '11g’
option path 'soc/soc:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0’
option htmode 'HT20’
option disabled '0’
option txpower '19’
option country ‘US’

config wifi-iface
option device 'radio1’
option network 'lan’
option mode 'ap’
option disabled '0’
option ssid 'yyyyy’
option key 'xxxxx’
option encryption ‘psk2+tkip+aes’

config wifi-iface 'guest_iface_0’
option disabled ‘1’

config wifi-iface 'guest_iface_1’
option disabled ‘1’

root@turris:~# iw reg get
country US: DFS-FCC
(2402 - 2472 @ 40), (N/A, 30), (N/A)
(5170 - 5250 @ 80), (N/A, 23), (N/A)
(5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS
(5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
(5735 - 5835 @ 80), (N/A, 30), (N/A)
(57240 - 63720 @ 2160), (N/A, 40), (N/A)
root@turris:~# iwlist wlan0 scan | grep Frequency | sort | uniq -c | sort -n
1 Frequency:2.412 GHz (Channel 1)
1 Frequency:2.432 GHz (Channel 5)
1 Frequency:2.437 GHz (Channel 6)
1 Frequency:2.462 GHz (Channel 11)
1 Frequency:5.765 GHz
1 Frequency:5.805 GHz
2 Frequency:5.24 GHz (Channel 48)
3 Frequency:5.745 GHz (Channel 149)

Cheers!


#17

Before i could clearly see that your htmode was on 40.

However now it is on 80, although you it does support lower, it has it’s cons. 40(802.11B,G,N), 80(802.11AC) or even 160 (802.11AD) just means what it up to it’s max can support. But logically it’s is clear for both of us, why we use 802.11AC (speed), so i would suggest, keep an eye on it to use it to it’s max right :).

Btw, if you would for example change to channel 36, what would change in the sense of croud-level of other wifi-routers using the channel? Because right now it doesn’t look like anybody using it. Or are you having multiple 5 Ghz SSID’s? Which also doesn’t look like it looking at your wireless configuration file.


#18

In my neighborhood, i’m surrounded by XFinity Wifi routers that are constantly changing their wifi channels as they see fit. I haven’t researched the system being used, but I’ve observed strange flock-like behavior where they’ll all settle at 36 and then all migrate to 48 several hours later. Birds of a feather…


#19

It must be that hotspot stuff. We also have that kind but those here are still on 2.4 GHz and change constantly to different channels also. I’m not sure what benefits a 5 GHZ hotspot would give you as it can’t reach large distances especially when we talk about walls between the routers and clients.

What you maybe could do is trick them in to believing your channel is crowded. How?. make multiple SSID’s on your 5GHz. Theoretically it should work. It would give the signal to those routers to not use the channel your SSID’s are on :smile: although none of them are in use except only 1 SSID. I am not sure what algorithm it uses to determine what channel is free or crowded but you could always just give it a try :).


#20

When running the last part of the command:

iwlist wlan0 scan | grep Frequency | sort | uniq -c | sort -n

I get this:

Interface doesn’t support scanning : Resource busy

What can I do now???