Installing of mSATA disk

Last weekend I installed mSATA disk into Turris Omnia router. Because there are few traps I would like to write an article into community documenatiton. Regarding this I would like to clarify a few questions.

Main installation steps are

  • hardware installation - video guide is solving it
  • disk fomatting and mounting setup
  • 2GHz wifi software installation - what are recommended steps after moving 2GHz wifi into another slot? I have found 2GHz wifi doesn’t work and I used steps mentioned here: Info: Small thing to do after adding mSata SSD

One last question: isn’t there any similar complete guide for installation on Turrisu Omnia?

Thank you for any answers in advance.

1 Like


I didn’t found any complete guide (as I searched for the same this weekend :slight_smile: )

I would recommend the 2,4GHz config adjustment as first step so user would not need to restart twice.

And IMHO the step mentioned in that link (regarding /etc/config/wireless) is sufficient when the 2,4 card is moved to the side slot:

config wifi-device ‘radio1’
option path ‘soc/soc:pcie-controller/pci0000:00/0000:00:03.0/0000:03:00.0’

I would personally appreciate also second part of this kind of guide for bit advanced users who would like to use sata disc instead of flash ( there is exroot guide but from what I found on the forum it seems to me that the exroot is not the best solution )

1 Like

Take a look at this thread: Switch to force mSata

1 Like

FWIW, I always felt that is the CLI could be used to make a configuration change, then (via a copy & paste), there was always less scope for making a mistake. With that in mind, here are some options…

When the 2.5 GHz card moves from mPCIe slot 1 to slot 3 (because the mSATA card must be in slot 1), then /etc/config/wireless needs to be edited as per all the various posts mentioned here and elsewhere…

The easiest way to acheive this (IMO), is to execute following command:

root@db-router:~# sed -i ‘/path/ s/01/03/g’ /etc/config/wireless

… to restart wireless networking with the new configuration (assuming the card is already in slot 3):

root@db-router:~# wifi

To be clear, this is a permanent change, and does not require a reboot. The sed command looks for lines containing ‘path’, and swaps ‘01’ for ‘03’.

I suggest you simply: a) execute the sed command as above, then b) immediately shut down the router and finally, c) move the card from slot 1 to 3. When you reboot (and wifi restarts), there should be no noticeable difference.

An alternative (better?) way may be to use UCI:

root@db-router:~# uci show wireless | grep path
root@db-router:~# uci set wireless.radio0.path=‘soc/soc:pcie-controller/pci0000:00/0000:00:03.0/0000:03:00.0’
root@db-router:~# uci commit
root@db-router:~# wifi

Again, no reboot required.

FYI: if you’ve pranged your wireless configuration, then the following commands may be helpful:

root@db-router:~# wifi detect > /etc/config/wireless

… and (these are commands that make changes to /etc/config/wireless via UCI):

root@db-router:~# uci show wireless
root@db-router:~# uci set uci set wireless.radio0.disabled=0
root@db-router:~# uci set wireless.@wifi-iface[0].ssid=MY_SSID
root@db-router:~# uci set wireless.@wifi-iface[0].key=MY_PASSWORD
root@db-router:~# uci set wireless.@wifi-iface[0].encryption=psk2+ccmp
root@db-router:~# uci commit
root@db-router:~# wifi