HW Problem with 5GHz WiFi - Direct firmware load for ath10k failed with error -2


#1

Hi,

after yesterday forced Factory reset I have a problem with 5GHz WiFi. This card isn’t loading anymore. Any idea?

dmesg:

[   16.881842] pci 0000:00:02.0: enabling device (0140 -> 0142)
[   16.887719] ath10k_pci 0000:02:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[   17.063275] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:02:00.0.bin failed with error -2
[   17.074015] ath10k_pci 0000:02:00.0: Falling back to user helper
[   17.083722] firmware ath10k!pre-cal-pci-0000:02:00.0.bin: firmware_loading_store: map pages failed
[   17.092841] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2
[   17.103239] ath10k_pci 0000:02:00.0: Falling back to user helper
[   17.112687] firmware ath10k!cal-pci-0000:02:00.0.bin: firmware_loading_store: map pages failed
[   17.129601] ath10k_pci 0000:02:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
[   17.138874] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 1
[   17.148402] ath10k_pci 0000:02:00.0: firmware ver 10.2.4-1.0-00029 api 5 features no-p2p,raw-mode,mfp,allows-mesh-bcast crc32 88595bb8
[   17.193132] ath10k_pci 0000:02:00.0: board id is not exist in otp, ignore it
[   17.200241] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/board-2.bin failed with error -2
[   17.210718] ath10k_pci 0000:02:00.0: Falling back to user helper
[   17.220279] firmware ath10k!QCA988X!hw2.0!board-2.bin: firmware_loading_store: map pages failed
[   17.230198] ath10k_pci 0000:02:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
[   18.359053] ath10k_pci 0000:02:00.0: htt-ver 2.1 wmi-op 5 htt-op 2 cal otp max-sta 128 raw 0 hwcrypto 1
[   18.451027] ath: EEPROM regdomain: 0x0
[   18.451032] ath: EEPROM indicates default country code should be used
[   18.451034] ath: doing EEPROM country->regdmn map search
[   18.451039] ath: country maps to regdmn code: 0x3a
[   18.451042] ath: Country alpha2 being used: US
[   18.451044] ath: Regpair used: 0x3a

log:
2018-01-27T09:39:12+01:00 notice netifd[]: radio0 (20280): nl80211: Could not configure driver mode
2018-01-27T09:39:12+01:00 notice netifd[]: radio0 (20280): nl80211: deinit ifname=wlan0 disabled_11b_rates=0
2018-01-27T09:39:12+01:00 notice netifd[]: radio0 (20280): nl80211 driver initialization failed.
2018-01-27T09:39:12+01:00 notice netifd[]: radio0 (20280): wlan0: interface state UNINITIALIZED->DISABLED
2018-01-27T09:39:12+01:00 notice netifd[]: radio0 (20280): wlan0: AP-DISABLED
2018-01-27T09:39:12+01:00 notice netifd[]: radio0 (20280): wlan0: CTRL-EVENT-TERMINATING
2018-01-27T09:39:12+01:00 notice netifd[]: radio0 (20280): hostapd_free_hapd_data: Interface wlan0 wasn’t started
2018-01-27T09:39:12+01:00 notice netifd[]: radio0 (20280): cat: can’t open ‘/var/run/wifi-phy0.pid’: No such file or directory
2018-01-27T09:39:12+01:00 notice netifd[]: radio0 (20280): Command failed: Invalid argument
2018-01-27T09:39:12+01:00 notice netifd[]: radio0 (20280): Device setup failed: HOSTAPD_START_FAILED


#2

Turris Omnia - rtrom01
Turris OS 3.9.6
Kernel 4.4.119-082ea0f4a4e204b99821bedcb349ed54-0
Compex WLE200N2
Compex WLE900VX (AC auto channel 80MHz)

similar output here in the kernel log

Loading modules backported from Linux version wt-2017-01-31-0-ge882dff19e7f
Backport generated by backports.git backports-20160324-13-g24da7d3c
pci 0000:00:02.0: enabling device (0140 -> 0142)
ath10k_pci 0000:02:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:02:00.0.bin failed with error -2
ath10k_pci 0000:02:00.0: Falling back to user helper
firmware ath10k!pre-cal-pci-0000:02:00.0.bin: firmware_loading_store: map pages failed
ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2
ath10k_pci 0000:02:00.0: Falling back to user helper
firmware ath10k!cal-pci-0000:02:00.0.bin: firmware_loading_store: map pages failed
ath10k_pci 0000:02:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 1
ath10k_pci 0000:02:00.0: firmware ver 10.2.4-1.0-00029 api 5 features no-p2p,raw-mode,mfp,allows-mesh-bcast crc32 88595bb8
ath10k_pci 0000:02:00.0: board id is not exist in otp, ignore it
ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/board-2.bin failed with error -2
ath10k_pci 0000:02:00.0: Falling back to user helper
firmware ath10k!QCA988X!hw2.0!board-2.bin: firmware_loading_store: map pages failed
ath10k_pci 0000:02:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
ath10k_pci 0000:02:00.0: htt-ver 2.1 wmi-op 5 htt-op 2 cal otp max-sta 128 raw 0 hwcrypto 1
ath: EEPROM regdomain: 0x0
ath: EEPROM indicates default country code should be used
ath: doing EEPROM country->regdmn map search
ath: country maps to regdmn code: 0x3a
ath: Country alpha2 being used: US
ath: Regpair used: 0x3a