How to upgrade a holdout Turris Omnia v3 in 2024

I have a holdout Turris Omnia device with version 3.11.23, foris version: 100.5.1, kernel 4.4.199-a890a… Is there still an upgrade path to 6.5?
Can I run the updater from shell or what should I do? Currently, I’m even afraid to power it off

I’ve enabled upgrades in Foris which installed the tos3to4 package, however the upgrade is not performed. I have 2 notifications in Foris UI:

Updater selhal:
[string "transaction"]:158: Collisions:
• /usr/bin/killall: busybox (new-file), psmisc (existing-file)
• /usr/bin/xz: busybox (new-file), xz (existing-file)
• /usr/bin/diff: busybox (new-file), diffutils (existing-file)
• /usr/bin/unxz: busybox (new-file), xz (existing-file)
• /usr/bin/cmp: busybox (new-file), diffutils (existing-file)
• /usr/bin/flock: flock (existing-file), busybox (new-file) 

Install worked for:

Update from 2024/02/16 13:12:11
• Installed version 1.06.95-1 of package bc
• Installed version 1.6 of package tos3to4-notify
• Installed version 11.10 of package userlists
• Installed version 1.0.3-1 of package tos3to4
[... removed a bunch of language packs, such as foris-netmetr-plugin-l10n-fr...] 

Clean installation of the latest version of the system according to the documentation

1 Like

You can take snapshot of your system and after clean install of version 6.5.2 mount it and change default settings according changes you made in v3… but, be warned, a lot was changed from v3 to v6 of Turris OS :wink:

There are lots of changes between 3.x and 4.x, then between 5.x and 6.x
It’s better to start from beginning.
If You do not want to play with usb and medkit, then quick idea is to manually update ca certificates (, then try to install schnapps (, and then update factory image with schnapps and rollback to factory.

But I have no idea what with dependencies.

Wait for TurrisOS 7.0 and then reflash:

Mode 4

1 Like

and the interviewer Dormitory4801 remains silent :frowning:

I didn’t know the update was finished, I left it thinking it’s still doing something. I’ll come back with the current state.

UPDATE: never mind, I haven’t brick it, I removed the USB stick and rebooted and nothing changed, yet I was afraid of my own shadow.

So I don’t really know what happened, I need to retry, I guess

1 Like

SOLVED: I’m not sure what was happening with the USB stick. Even though it was supposed to be able to read BTRFS, I guess it could not read it. I tried to manually mount the drive and check the router can read the files there. That seemed like the money shot, as even though OpenWRT’s LUCI interface was showing the USB as mounted and recognized its BTRFS filesystem, it was showing no files present. I guess it wasn’t really properly mounted.

The update went on just fine after I’ve formatted the same USB stick with FAT32 and put the files on that partition.

BTW, I like the new welcome / setup wizzard. I haven’t managed to test anything else yet


Good to hear from you.

1 Like