How To setup WDS

Hi,

I want to setup my Mox to extend the WLAN Range of my Omnia. I have no Ethernet cable between Mox and Omnia location:

             +--------+              +--------+
Internet --- | Turris |----<WiFi>----| Turris | 
             | Omnia  |              |  Mox   |
             +--------+              +--------+
               |   |                       |
               |   +--<WiFi>-- Clients     +--<WiFi>-- Clients
               |
               +--<Ethernet>-- Clients

I found a tutorial in the OpenWrt Docs, but I cannot get things running. It only works with Ethernet Connection between Omnia and Mox.

Has anyone working tutorial for that or useful hints?

omnia wifi has option wds ‘1’ set for channel 1

mox /etc/config/wireless is:

config wifi-device 'radio0'
    option type 'mac80211'
    option channel '36'
    option hwmode '11a'
    option macaddr '...'
    option htmode 'VHT80'
    option disabled '0'
    option country 'DE'
    option legacy_rates '1'

config wifi-iface 'default_radio0'
    option device 'radio0'
    option network 'lan'
    option mode 'ap'
    option ssid 'mox-ssid'
    option disabled '0'
    option encryption 'psk2+ccmp'
    option wpa_group_rekey '86400'
    option key '-..-'

config wifi-device 'radio1'
      option type 'mac80211'
      option macaddr '...'
      option disabled '0'
      option channel '1'
      option hwmode '11g'
      option country 'DE'
      option legacy_rates '1'

config wifi-iface 'default_radio1'
    option device 'radio1'
	option network 'lan'
	option mode 'sta'
	option ssid 'omina-ssid'
	option disabled '0'
	option encryption 'psk2+ccmp'
	option wpa_group_rekey '86400'
	option key '...'       

config wifi-iface 'guest_iface_0'
	option disabled '1'
	option device 'radio0'

config wifi-iface 'guest_iface_1'
	option disabled '1'
	option device 'radio1'

This worked for me.

[OpenWrt Wiki] Wireless Repeater/Extender with WDS

Hi Jack,

I tried it from the same page You mentioned.
Can You see if there is a bug in my configuration, or send my your /etc/config/wireless ?
ATM my Mox does not connect to the Omnia via WiFi.

Hi Milaber,

I configured my equipement via Luci GUI. Reading/editting the config files is not for me.
As soon as I have acces to my equipement (later today) I will post my config files so you can have a look at them.

BTW: My set-up is slightly different
ISP (Modem) — TO (Router-AP) ---- Netgear R7800 (AP) — wds— Archer C7
I dont allow wifi clients on the Archer only ethernet connections.
The wds link on the Archer is made by the 2.4 GHz, the 5 Ghz is disabled. I guess enabling the 5 GHz would allow wifi clients (did not try this).

Here are mine config files. Hope they help you.

R7800

etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fde7:85e4:91e8::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.2'
	option gateway '192.168.1.1'
	option dns '192.168.1.1'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 0t'

etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'VHT80'
	option country 'US'
	option legacy_rates '1'
	option channel '40'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'SkyNet node 5'
	option encryption 'psk2+ccmp'
	option key '************'
	option wpa_disable_eapol_key_retries '1'
	option wps_pushbutton '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
	option htmode 'HT20'
	option country 'US'
	option legacy_rates '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option wds '1'
	option ssid 'SkyNet node 24'
	option encryption 'psk2+ccmp'
	option key '****************'
	option wpa_disable_eapol_key_retries '1'
	option wps_pushbutton '0'

ArcherC7

etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd66:9404:04b6::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option dns '192.168.1.1'
	option ipaddr '192.168.1.3'
	option ifname 'eth0.1'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'
	option auto '0'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'
	option auto '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 4 5 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 0t'

etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'VHT80'
	option channel '40'
	option legacy_rates '0'
	option country 'US'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'SkyNet node 5'
	option encryption 'psk2+ccmp'
	option key '**************'
	option wpa_disable_eapol_key_retries '1'
	option disabled '1'
	option network 'lan'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/qca956x_wmac'
	option htmode 'HT20'
	option legacy_rates '0'
	option disabled '0'
	option country 'US'

config wifi-iface
	option ssid 'SkyNet node 24'
	option encryption 'psk2'
	option device 'radio1'
	option mode 'sta'
	option bssid '**:**:**:**:**:**'
	option key '**************'
	option wds '1'
	option network 'lan'

thx jack,
i’ll be back home on friday - will check then …

Just another guide: https://doc.turris.cz/doc/en/public/repeater. I haven’t tried, but I want to.