How to permanently apply ethtool speed setting?

For some reason the wiring in my house just doesn’t like gigabit speed, so I have to use ethtool to disable gigabit. How can I have this automatically applied after a reboot? It appears the system isn’t using either ifupdown or systemd to configure the network.