How to mount USB drive?

Hello Friends,
I want to use USB3 drive for Majordomo database. All I done was format to ext4 from omnia shell and rebooted router.
My usb was listed under System\Mount Points as /tmp/run/mountd/sda1 .
Why it is automatically mounted as /tmp/run/mountd/sda1?
I wanted to change it as /mnt/sda1 , how can I do that?
(When I try to change fstab to:

config mount
option device ‘/dev/sda1’
option options ‘rw,sync’
option target ‘/mnt/sda1’
option enabled ‘1’
option fstype ‘ext4’
option enabled_fsck ‘1’

I ended with 2 mounted file systems:

Sorry for late answer.

I don’t have time to play with Omnia, yet. But few days ago I did it for previous Turris. It should be the same.

When I plugged my USB Flash drive into Turris I run these two commands on SSH:
blkid and also df-h (which I recognize if it is mounted)

When it wasn’t mounted I go to LuCI - System - Mount Points

I also look at mounted file systems that it isnt there and then I move my eyes to Mount Points, where click on Add.
Tick - Enable this mount and choose device on UUID list and on Mount point you choose custom and write there where that it should be mounted in this case: /mnt/sda1

When it is done so it should look like this (I have different paths): (where you can see that I have mounted usb flash and also SD card)

Pepe, was just a bit faster then me. I was trying to get the openwrt (virtualbox image) starting.

Addition to what Pepe said. Keep in mind that the UUID when you are going to use, will change i you format the USB drive.

if you ever need to get the uuid out of a drive:

dumpe2fs -h /dev/sdX | grep -i uuid

replace X with whatever letter the drive is.

That’s not neccesary. Blkid shows UUID :wink:

thank you all, I already manage it.
the only problem is that even I deleted (by pressing Unmount) original mount point /tmp/run/mountd/sda1 it will re-appear after restart. how can I get rid of this second instance?

Usually in the fstab you can clearly define what UUID to mount on what mounting point. I just opened openwrt (Virtualbox), i tried to edit fstab, it was empty. I am not sure if this was because i am running in virtual enviorment or nothing is mounted.

Could you maybe post the fstab file please.

This is my fstab:

config global
option anon_swap '0’
option anon_mount '0’
option auto_swap '1’
option delay_root '5’
option check_fs '1’
option auto_mount ‘1’

config mount
option device '/dev/sda1’
option options 'rw,sync’
option target '/mnt/sda1’
option enabled '1’
option fstype 'ext4’
option enabled_fsck ‘1’

It looks like some built in automatic mount…:cold_sweat:

As you can figure from mountpoint name - it’s handled by mountd - automount daemon. Its config is in /etc/config/mountd.
Fstab is handled by block-mount package but on my omnia command block info doesn’t see my USB drive. It only lists mmcblk0 device, while blkid lists all labelled block devices. So I gave up trying and just rely on mountd now as it is the only way to mount my external usb storage. (without custom scripts)

Take a look at this, which also makes a bit more sense what ruff is talking about (mountd …block-mount)…

Also some valuable information for me. Give me some time to also read this and understand how this is working.

Yes, in Unix there is typically more than one way to accomplish the same thing. blkid isn’t any better or worse, just different.

block info is apparently worse than blkid - former doesn’t show my 2T xhci usb device while later lists them all.
And since it doesn’t show - it also doesn’t mount. While again - mountd mounts it. Even though I cannot call ut better as it’s less configurable.