How to mount USB device

I would like to copy a schnapps backup to an external usbdevice.
Unfortunately turris 4.0.5 does not show the usb storage using fdisk -l.
Any idea what’s wrong?

Schnapps image is exported E.g. to to /srv/ … if created? And what sftp transfer withE.g. Bitvise SSH Cllient or other ?

export image to flashdisk with /srv/
schnapps create 3.11.3 back
schnapps export 169 /srv/backup

acces to folder with images schnapps
na SSD … mount /dev/sda1 -o subvol=/ /mnt/snap
orig lokation … mount /dev/mmcblk0p1 -o subvol=/ /mnt/snap

Thank You but your answer does not match my question. Probably I was not very clear in my description.
Creating the Schnapps image works fine. But I cannot copy it to a USB stick. After inserting the USB stick, it is not displayed with fdisk -l. So I cannot mount it.
Do I need to install additional software under 4.0.5 to work with USB sticks?

Foris - Updater - NAS Services allowing to connect a disk to the router and use it as network data store.
Luci - Sytem - Mount point

You havent no one flash disk as /srv/ ? Via Foris - Storage ? It is recommeded for less load for internet memory and his long life.

Of course I have a flash disk. But I want to connect an external usb storage to the external port at the turris omia device for data transportation.
I will check the NAS services. I sounds a little bit strange to activate NAS services to use a normal usb stick. Using TOS 3.x this was not necessary.
Thank You!

If it doesn’t show up in fdisk -l that could be a potential problem. What filesystem does it use? Does the device show up in dmesg when you plug it in? And does it show up in lsusb? Could be missing kernel drivers, or a problem reading the flash drive.
You can check if it’s missing drivers by checking /sys/kernel/debug/usb/devices, Driver will say (none) in that case.

The usb stick uses ext4.

dmesg shows:
[221552.829183] usb 5-1: new SuperSpeed USB device number 2 using xhci-hcd
[221552.860092] usb-storage 5-1:1.0: USB Mass Storage device detected
[221552.866487] scsi host2: usb-storage 5-1:1.0
[221553.949922] scsi 2:0:0:0: Direct-Access SanDisk Ultra 1.00 PQ: 0 ANSI: 6
[221553.959050] sd 2:0:0:0: [sdb] 60063744 512-byte logical blocks: (30.8 GB/28.6 GiB)
[221553.967495] sd 2:0:0:0: [sdb] Write Protect is off
[221553.972405] sd 2:0:0:0: [sdb] Mode Sense: 43 00 00 00
[221553.977820] sd 2:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doesn’t support DPO or FUA
[221553.992540] sdb: sdb1
[221553.995934] sd 2:0:0:0: [sdb] Attached SCSI removable disk

lsusb shows:
Bus 005 Device 002: ID 0781:5581 SanDisk Corp. Ultra

Now mounting with /dev/sdb1 worked!!!

Obviously a “layer 8” problem.

Thank You.

Super ! Remember to “Storage” … /srv/ for long life int. memmory. Be me is already dead and my system is on mSATA SSD.