How to do a 'simple PPOE' connection

I have scanned the forum and internet but I cannot get an answer or the following working:

My office gets a ethernet connection, have to login via PPOE.
So, I can connect the Turris to the ethernet via the WAN port and use my macbook to start a PPOE connection.

Downside: turris cannot update, no other connections possible. I really want the Turris to handle the ppoe stuff.

I can also connect my macbook directly to the ethernet without the Turris and connect to the internet.

I just have a few settings from my isp:
Fixed IP, Login, passwd, primary dns, secundary dns.

I tried to configure the ‘pptp-wan’ port to login via PPOE but it does nothing. Also tried to connect one LAN port instead of wan, and configure this to do a ppoe login.
Updated the firmware to latest (3.10.5) version and tried a bunch of other things, which did not work. So i am clearly overseeing something :frowning:

What is the simpelest way to configure a ppoe connection? have been trying for days now.

Log into the Foris frontend, select WAN -> IPv4 protocol -> PPPoE | PAP/CHAP username | PAP/CHAP password

thx. This was the first thing I tried out of the box, and after the latest firmware update. Never works, always the “You WAN configuration is probably not correct or your WAN interface hasn’t been properly initialized yet” message.
Also tried this via the Luci interface.

This simple kind of setting does work in my mac, and windows. The connection is a glassfiber Vlan. The vlan part is managed in the server room. I just have to do the ppoe login on my end.

That is a rather curious setup since PPPoE is common for DSL connections but not so much for full fibre.

I am not familiar with the MAC but if am not mistaken on WIN PPPoE is sort of a dial-up connection type and emulating a software modem for that purpose. The TO router does not provide a modem (or emulates one) and thus expects a DSL modem or bridge.

Despite the fibre line (between ISP and that mentioned server room) are you sure that service provided is not VDSL?

Hmh, just read something about passive optical network (PON) and PPPoE over GPON which might be true in your case.

As far as I know the TO router has no support for PPPoE over GPON but I might be wrong and you might want to open a ticket with the TO support.

pppoe should work regardless of the carrrier-medium (dsl/fibre), setup should be straight forward as mentioned.

maybe you have to set some extra bits in openwrt that are guessed correctly by macos or maybe you are limited by mac-address.

you should talk to you “networking guys”, bring some candy and mention openwrt.

1 Like