How to do a new install of Pi-Hole?


#1

Now that 3.11 is out of RC, has anyone tried installing Pi-Hole into a a new container?

No matter what host OS I tried, I could not get pi-hole 4.1 to complete a successful install. I was curious to know if anyone else has, and what you did to get it to work?

Thanks,

-Rob


#2

With RC 3.11.1 I just set up a fresh unbuntu cosmic container, then apt update then apt install curl then curl -sSL https://install.pi-hole.net | bash.

Then went through the scripted setup screens and things seemed fine except the setup ended with

/usr/local/bin/pihole: line 296: pihole: command not found

The server though appears up and running judging by the output from ss -tulpnoiwe

Summary

NetidState Recv-Q Send-Q Local Address:Port Peer Address:Port

udp UNCONN 0 0 0.0.0.0:53 0.0.0.0:* users:((“pihole-FTL”,pid=8310,fd=4))
udp UNCONN 0 0 :53 : users:((“pihole-FTL”,pid=8310,fd=6))
tcp LISTEN 0 0 0.0.0.0:53 0.0.0.0:
users:((“pihole-FTL”,pid=8310,fd=5)) uid:999 ino:712383 sk:e6b1b980 rto:1 cwnd:10 reordering:0
tcp LISTEN 0 0 127.0.0.1:4711 0.0.0.0:* users:((“pihole-FTL”,pid=8310,fd=10)) uid:999 ino:712975 sk:e6ae5640 rto:1 cwnd:10 reordering:0
tcp LISTEN 0 0 *:53 : users:((“pihole-FTL”,pid=8310,fd=7)) uid:999 ino:712385 sk:eae38c80 rto:1 cwnd:10 reordering:0
tcp LISTEN 0 0 [::1]:4711 : users:((“pihole-FTL”,pid=8310,fd=11)) uid:999 ino:712977 sk:e9f7abc0 rto:1 cwnd:10 reordering:0


#3

Thank you. The very same error I got. I just assumed it didn’t finish completely, but perhaps it reached a point of the install where it is functional. The pi-hole dev’s and forums have not been of particular assistance here. They are indifferent towards the issues I posted.


#4

had that issue also, and that issue is also known on their forums.
pi-hole install seems ok.
but only thing that was missing was that password for admin page was not set.
maybe install script wanted to end with pihole -a -p to set password of admin page and somehow could not find executable

i executed:

echo "alias pihole='/usr/local/bin/pihole'" >> ~/.bash_aliases && source ~/.bash_aliases

and after that pihole -a -p to set password