How to configure a lan port for TV decoder

Hi all,
My Turris omnia seems to work like it should, except:
I can not connect my decoder.
When I do it gets an ip address in the same range as the router; 168…
It should be 10…
Is there a way I can fix that problem?
Maybe configuring my last lan port (lan4) to go to my decoder?
Or is there a better and easier option?

That’s because your (Telenet) decoder needs be connected directly to your WAN, and not the LAN. You can do this by placing an extra switch before your Turris Omnia router, or bridging one of the LAN ports with the WAN port.

You can find some info in this topic:


(Your setup is a bit less complicated because you don’t seem to need the vlan trunk part of the setup.)

Bridging one of the Lan ports with the Wan is what I intended to do but don’t know how.
I will try to solve it via the link you sent me. I will get back to you later to let you know the result.
Thanks in advance.

I would like to use LAN4 to go directly to my telenet decoder.
How do I configure the router to do this?

Did you setup a DHCP 10.x subnet for a specific lan port or why/how is the 10.x subnet expected for the decoder?
Which TOS branch is the TO on?
What is the decoder brand/model, manual in EN available online?

I did no setup for DHCP 10X addresses.
In the attached picture you can see what the ip’s should be.
The brand of the decoder is unknown because from my ISP and no manual.

What is TO?settopBox

Turris Omnia


From the MAC lookup it would appear to be a device manufactured by ADB ( Advanced Digital Broadcast SA), probably one of those [1] branded by the ISP

The manuals exhibited are lacking any information about how to setup ip on the decoder…


The image is displaying the IP-information, presumably the whole 10.x subnet preset by some other party (ISP?). However there should be also an IP-Settings page and on that the IP should be set to DHCP and default gateway to auto(matic) (or something similar). And if you do not like the providers’s DNS server to be used set it to auto too.

After changing/applying the IP settings on the decoder it should work as expected but with the current mismatch of the IP subnets it will not.


[1] https://www2.telenet.be/nl/klantenservice/handleidingen-en-andere-documenten/

Correct: it is ADB.
But still don’t know how to setup my TO.

The Telenet decoder needs be connected directly to the cable modem. The decoder will get a 10.x.x.x address (dhcp), while all other devices will end up in a completely different subnet. Is assume this is based on the mac address. As far as I know, the IP settings on the decoder can’t be configured.

If you place the decoder behind a router, it will get a private address (e.g. 192.168.x.x), but then it won’t work. So either you have to place a small switch before the router and connect the decoder to that switch, or modify the router config to pass-through WAN traffic on one of the LAN ports (e.g. bridge one of the LAN ports on the router with the WAN port).

1 Like

This INHOME IP ADDRESS does not look like something of a common industry standard and without a proper manual for the decoder it is difficult to understand how that device is to be set up properly behind a router.

(Soft) Bridging a LAN port with WAN is not necessarly the best practice but if that is what takes than it can be managed through LuCI (Foris does not provide such facility) or editing the /etc/config/network via ssh.