How to access samba through Wireguard


Currently I can access to samba only by smb://

When I try smb:// cant access, router wg interface has ip

Will adding below to the samba cfg help?

hosts allow = 10.0.10.

But how to add it, the samba cfg is written in OpenWrt lang, dont know what option parameter to be used for “hosts allow”.

Samba is only listening on ‘lan’ by default.
In Luci, under Network Share it can be linked to another interface, including Wireguard.
Settings are saved in /etc/config/samba4

Many thanks, going to try that.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.