Help with Omnia bandwidth limiting?


#1

hello, i dont know enough to investigate what is happening, can you help?

my modem is consistently producing 0.9+ Gbps / 0.2+ Gbps but my Omnia directly connected to it somehow never produces the same results, often making only half of this available down (sometimes only 30% even), and about 80% up-wise.

iv recently been helped eliminate buffer bloat here with QoS (Cake, tried both ‘piece of’ and ‘layer of’) but global bandwidth is still hampered (also tried removing QoS entirely). my stock modem router doesnt suffer buffer bloat, and speed, latency and jitter are phenomenally better than with my Omnia configuration… i imagine this can’t be normal and would really welcome any hints or tips to get my Turris up to speed.

thx for reading


Router/switch bandwidth restrictions in PPPOE
#2

how is cpu-load during testing?

you could try with a default config and some services like pakon or other monitoring disabled …


#3

Well, traffic-shaping is costly and hence can restrict the achivable bandwidth. You could try to set the Downstream Shaper to 0 (to disable it) as your router should have enough punch for upstream shaping, that way you could reap the benefits of cake where it probably matters most on your connection, and you will only pay the comparatively smaller CPU-price for 0.2 Gb (which still should be in the range an omnia should be able to handle, but that depends on how much other duties you gave the omnia, traffic shaping at such high bandwidth is almost a full-time job for a router ;))


#4

thank you @hadc! bandwidth fully restored! monitoring was really taking its toll.

thank you @moeller0, download shaping was ultimately the issue and shaping just upload traffic is working fine as you suggested. ps: giant thank you for the amazing QoS and Cake tutorial with @iddqd - textbook thread!