Help with first set-up Turris Omnia using SFP ALL4781 VDSL Modem

I am starting with:

  1. A brand new Turris Omnia, never connected to the Internet.
  2. A brand new ALL4781-VDSL2-SFP as a modem.
  3. DSL from O2 in Germany

What I don’t have:
I don’t have any stand alone DSL modem at hand. The ISP does not provide any for free and as the ALL4781 is not a cheap joy, I hope that I will not need to buy another modem.

I tried to read the old topics on this subject in the forum.

Some report:

I just disconnected the Modem, Inserted the SFP-Module, connected it to the Telephone-Line with the existing cable and it just worked.

With me this is unfortunately not the case even when I have configured the WAN interface with the ISP credentials.

Some write:

Run once: /etc/init.d/sfpswitch enable; /etc/init.d/sfpswitch restart && /etc/init.d/network reload && echo ‘Success’ || echo ‘Failed’

I connected over SSH to the Turris Omnia and unfortunatelly I was not able to find /etc/init.d/sfpswitch or to execute it.

Some write about /usr/sbin/ but hey surprise! I am not able to find this file as well.

Some write about
ln -sf armada-385-turris-omnia-sfp.dtb /boot/dtb && reboot
This one I was able to run.

I was also able to run
root@turris:~# i2cdump 5 0x50
And I got the expected message with ALL4781 in it. Which is at least an indication that the SFP is working to at least some extend and that it recognizes the ALL4781.

Could somebody help me and give me a guidance how to proceed and how to get my Turris Omnia to be able to connect to the Internet? Maybe some step by step what you would do if you were on my place.
P.S. I am not a software developer.

I solved the problem. The solution was more trivial then expected.
The ifname of the WAN had to be set to eth2.7
2 because in the later batches of Turris Omnia the SFP is behind eth2. So be careful with older manuals!
And .7 because O2 expects VLAN7 and this is the wasy to pass the parameter. So eth2.7.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.