Help noob to configure wan please

Hi, could you help me with wan configuration?
I’m really lost, I don’t know what else to do

I did reset, I’m using latest OS available, ISP is Movistar Spain with FTTH fiber

I tried to configure it from fortis and from luci like this

but I still can’t get it to get to the internet from a web browser

I see mentioned in that post:
“You don’t have to change anything in the Switchsection, the WAN socket doesn’t go through the switch. Just change physical WAN interface from eth1 to eth1.6.”

“In the case of movistar, and assuming that you don´t have IPTV or phone over ip, it´s only configure WLAN with tagged traffic with ID 6 (so eth1.6), and as Ondrej pointed, you only need to setup the WAN interface as custom and et voilá.”

I also used this script before
mentioned here
Easy configuration script for movistar ISP ftth fiber (spain) - SW tweaks - Turris forum
but it is not an optimal configuration and it did’t work last time I tried

I did create a vlan like this, as advised in the first link

Should I modify anything here?
(Sorry for bad pics, no internet and bad phone at the time)

Hi noob

This is all I have under the switch configuration.

Try to drop the second line.

Thanks a lot for the answer. Unfortunately doing this too doesn’t seem to solve it and get a connection. I must be missing something else. I configured just like in all the previous screenshots, including yours-
What else could it be?
How would you configure it from a clean reset?

The screenshots in my original post are “work in progress” and probably incorrect. This is how it’s configured now:



I also did like in your last pic

I think I found that the main culprit of my connections problems with this ISP is the dns stuff. I tried deactivating dnssec and now it connects, although I still get connection error with some apps like youtube or newpipe in androids

What do you suggest to do with dns? Maybe it’s just an exclusive error with Movistar ISP?

BTW what do you get here in the connection test?

For me it passes with 100%. Can you successfully ping an ip address, for instance What if you connect your computer directly and bypass the router? Sorry, but I’m a notice when it comes to network configuration.

Ok so I enabled DNSSEC again to test
I can ping

I can browse internet, but most of the times, pages take like 10 secs to try to load, and then it says its unavailable. I reload and it usually loads the page fine the second or third time, although slow

Now I get this in that test, do you have any idea about where or how to configure IPv6?

I’ve also read people complain about not being able to use dnssec with movistar. Are you on that isp with fiber too?

And no idea about what you mean to bypass the router, mine is connected directly to the ONT device provided by the ISP

Thanks a lot for your help, at least I can now connect with it, more or less. I would like to correct these issues and learn to use all its potential

Can you not connect the computer directly to the ONT? Or use a different router to test? Though I assume the issue is with your router configuration. It took me 2 weeks to connect and it was a super frustrating experience.

I’m with a different provider in a different country.

“Can you not connect the computer directly to the ONT?”
I had no idea that was possible. ONT is far away in the house, and I don’t have a laptop. I may try somehow

I have other routers with openwrt, where I used that movistar configuration script I mentioned on the first post. They work perfectly, except they get much much slower internet connection

Those don’t have dnssec feature I guess. So I suspect it’s one of the things causing issues with movistar isp. I had it disabled in the past in turris because of this. But I didn’t even remember XD

Internet seems to mostly work now, so I’m happy I can use it again.
Do you know if I should configure IPv6 somewhere in luci?

Edit: I may be trying to fix something impossible. I see people complain about dnssec or ipv6 with spanish movistar isp