Help configuring VLAN for WAN

Hi there:

I found several topics in which VLAN topic is discussed, but i still not able to configure my Omnia to connect with my internet provider (Movistar FTTH - Spain).

My provider requires that the traffic over the WAN interface is tagged with id 6, and the rest can be untagged (I don´t have other services like IPTV or phone over ip). With other routers is fairly easy to configure, even with openwrt, but with omnia every attempt seems to fail. Anyone could explain how i must configure the “Switch” section in Luci?

Thank you!

I’ve been struggling with the same issue for days (my provider in XS4ALL FTTH in The Netherlands). Today I finally managed to get the router connected to the internet. Hopefully we can sort this out together :slight_smile:

These are the relevant settings (assuming that you are using the wan port on the router):

Editing the switch configuration is actually not needed, adding a “custom interface” (eth1.6 - for VLAN 6) as per the second screenshot is enough!

You don’t have to change anything in the Switch section, the WAN socket doesn’t go through the switch. Just change physical WAN interface from eth1 to eth1.6.

1 Like

You are right. I removed the entry and it still works. The wired clients are also accessible now. Thank you so much! I will update my previous post too. On to the next challenge, there’s so much to learn!

Switch section is only required, if you want to add different vlans to LAN side.

Thank you! It worked perfectly.

Hi krasny,

I’m having the same issue with my setup but in my case for Orange FTTH - Spain.

One question: with movistar, do you also need a user and password to setup the WAN?

I’ve been reading about configuring routers with openwrt for Orange FTTH and they say you need to

  1. Create a new Switch for VLAN with ID 832 (o r20)
  2. Create a new interface called DHCP and use eth1.832 (o r20)
  3. Set the WAN protocol to PPPOE so that you can enter the user and password for Orange and use eth1.832 (o r20)
  4. Change the WAN6 physical interface to eth1.832 (o r20)

This method did not work in my case though. I’m goona try your’s today but I wanted to know if we have similar needs in terms of configuration.

Thanks

Thank you, it worked beautifully!

Hi!

Were you able to configure your router for Orange?

In the case of movistar, and assuming that you don´t have IPTV or phone over ip, it´s only configure WLAN with tagged traffic with ID 6 (so eth1.6), and as Ondrej pointed, you only need to setup the WAN interface as custom and et voilá.

Yes thank you. I was able to configure the router simply by changing the physical WAN interface to (in the case of orange) eth1.832

WAN6 (for IPv6) still doesn’t work but that’s ok for now. The change is abysmal in my case and I’m very happy with the result right now. I will progressively get into more options.

Tanks again for your help!

I also have Orange (ES) but over a fibre line from Movistar (NEBA). Apparently, then it has to run over VLAN 20. I needed to clone the MAC, and then set the underlying interface (eth1) to either promiscuous mode (ip link set eth1 promisc on), or shut the interface down and then change the mac there too (ifconfig eth1 hw ether <mac>). Then DHCP would get a lease, and the traffic flows.

I have created wan2 using eth1.6 as described in this thread. How do I determine which Omnia port to plug the second wan link into? My existing link via the Omnia WAN port works fine; but I’m not successfully connecting thru the new wan2.

My “VLANs on Switch 0” display on the switch tab does not include the port status graphics indicating which ports are connected. I see only the two VLAN information rows. Any idea why?

I have been following these openWRT doc pages in my 2-wan config:

At this juncture I think I have resolved my “which physical port on the back of the Omnia” question. Also I’m no longer using 1.6; rather 0.3, which is the vlan created as described in the above linked pages. No connection thru to internet on wan2, as yet.

What are you trying to achieve? This thread is not about setting up 2 wan interfaces, but about setting up a wan connection on a specific VLAN. My understanding of both the router and openwrt is still very limited, but I think eth0.x is port 0-3 and eth1.x is port 6 (which is the wan port, for numbers refer to the screenshot above).

I am attempting to configure a second wan interfaces for concurrent use with the wan port - two different ISP links. I expect to use mwan3 for load balancing. My wan interface works via the wan port. I don’t seem to be making the hardware interface connection for wan2.Note that the openWRT doc mentioned in my previous post adds a vlan as one of the setup steps.

My installation does not display the Port Status line / images, as in your image:

I’ve been looking at vlan.lua, and suspect that the “missing” code would go here:

                        local pt
                        for pt = 0, num_ports - 1 do
                                local name

                                name = (pt == cpu_port) and translate("CPU") or translatef("Port %d", pt)

                                sp:value(pt, name)
                                mp:value(pt, name)
                        end
                end

**>>>>>>> I think the graphic with the status by port would go here <<<<<<<<<**

-- VLAN table

s = m:section(TypedSection, "switch_vlan",
                        switch_title and translatef("VLANs on %q (%s)", switch_name, switch_title)
                                                  or translatef("VLANs on %q", switch_name))

Could you kindly post the relevant part of your vlan.lua file so that I can figure out how to make this graphic status display work? Or is there an extension that I need to install to create it?

Thanks!
Robert

My code looks exactly the same and I haven’t made any changes to the standard configuration. Don’t think it will help, but here is the whole file.