Google DNS option has issues with Bmabu Labs 3D printers and Amazon Echo dot

Bambu Labs 3d printer wouldn’t bind the printer to the cloud, and the Amazon Echo Dot wouldn’t register. I believe that Bambu Labs uses the Amazon Cloud(don’t quote me on this).

I had initially selected the Google option for the DNS
When I changed this to Cloudflare, it they both instantly started working. I changed the option back to Google, and they both stopped working again.

I don’t know what particular names these were, but the symptoms sound very much like still this Google’s bug, unfixed for months: