Garmin products unable to use Wifi despite IP address attributed


I own a Garmin connected scale but it cannot connect using Turris Omnia.
I tried it using my phone as a connection point and it went fine.
I tried to disable WIFI from Omnia and use another WIFI router based on OpenWRT that use to work with my previous router (PFSense with no WiFi) => KO.
As the main difference is the router between the fiber 2 LAN converter and the WiFi router, I’m wondering if there may be something in the configuration that is causing the change of behaviour…

Any suggestion ? Recommendation ? Diagnostic steps to propose ?



1 Like

Have you tried changing the WiFi channel to something lower like 1-7?

Aha! I have the same problem!

It works with a mobile vodafone 4g hotspot but not the Turris, I have even tried putting the Garmin Scale on a DMZ within the Turris but no luck.

I am using the same 2.4 GHz channel as I was with my old router, I can see it get an IP address but it then fails to call home to the Garmin servers, hard to diagnose further as I don’t know what Garmin has as a workflow to determine the connection etc I have raised a ticket with Garmin for assistance but they have been very slow so far!

I wanted to use TEE module to see if it was something in the firewall but that is presently unavailable on the Turris

I too would welcome any proposals on how to diagnose this, it is either the Turris or my broadband supplier’s network (UK BT) causing the problem.

1 Like

OK - I managed to discover I could tcpdump the traffic on the router then look at it with wireshark. I should point out I have very little experience here!

I can see the Garmin Scales ask for DHCP and then receive an IP from the Turris router
Scales then ask Turris for DNS
Turris replies, and Scales then NTP successfully with
Scales then ask Turris for DNS (1st)
Scales then ask Turris for DNS (2nd)
Turris responds with DNS details for (2nd)
Turris responds with DNS details for (2nd)

Scales then ask Turris for DNS (again) (1)
Scales then ask Turris for DNS (again) (2)
Turris responds with DNS details for (again) (2)
Turris responds with DNS details for (again) (2)

This DNS request and response seems to go on for the next 50 secs or so, and eventually the Scale concludes it can not connect, so times out. The wireshark log shows the Turris not to respond to the first DNS query, but respond twice to the second query.

On my phone, I have a Garmin app, this communicates over wifi successfully with I have also tried another Garmin device (Edge 1000) over wifi, that works fine too though I note it doesn’t do any NTP (presumably as its a GPS device, so knows the time from there).

Perhaps the problem is with either the format DNS response from the Turris or the interpretation of the DNS response by the Garmin Scales?

I have a pcap of the above interaction if that helps? Unable to attach it to this forum unfortunately.

I followed the steps in this thread to change the DNS package and my scale now works!

Can you please make a new pcap now that it’s working and send me both of them? I think in could be interesting to find out the root cause.

Please use some file sharing service like

So I would appear to have been a bit premature on calling this solved, I haven’t been able to repeat the success since! :frowning:

Anyway, one good thing that has come of this is that the Scales now resolve the IP and start a conversation with it, but that is as far as it gets.

Here’s the none working standard installed DNS stuff:

and here’s the now working DNS stuff based on the ‘slow dns’ thread replacement of the standard DNS with dnsmasq-full plus the removal of ‘Option Port 0’ :

I would note I still have to manually stop kresd on each reboot…

Thanks for any help to can provide :slight_smile:

Thank you, very interesting. I can’t see any difference between DNS responses in each cases. But since there is no connection attempt at all, it looks like the scale somehow dislikes the DNS response it gets.

It is also interesting that all packets are duplicated. But it certainly haven’t prevented the scale from contacting the NTP server.

Yes I’m a bit stuck now, a few too many variables at play!

Could it be something in the ISP network causing the problem? (4G hotspot works, so Vodafone 1, BT Internet 0!)
However, my other Garmin devices/apps all play nicely on the same network (wifi & wired, BT Internet) so that points more to the scale being the problem!..

I have tried forwarding all ports to the scale on the firewall as well just in case there was something strange it was trying to expose to the internet, but from looking at the pcap it doesn’t appear to be the a problem.

I’ll repeat the process of trying to get the scale to work a few more times - perhaps there’s something randomly interacting.

Hi all,
I will have some time later today to test it more.
DNS is a good lead as I am almost certain it is not WIFI related.
I used to have this setting :
Fiber from ISP — Converter to ethernet (multiple VLAN) — pfsense router ---- WIFI (TPLink with OpenWRT) — Scale
Now, I have this :
Fiber from ISP — Converter to ethernet (multiple VLAN) — Turris Omnia (integrated WIFI) — Scale
(with a near future plan to use the Fiber SFP in the converter directly in the router).

The garmin Scale worked well before I switched to Turris Omnia. In order to diagnose the WIFI problem, I disabled it on the router and put back in the mix my old WIFI access point. (— Internet — Turris Omnia (no WIFI) — TPLink — Scale)
The scale didn’t work either, therefore ruling out a problem with the WIFI and more a problem with the way the router interacts with the local network and the internet.

Thanks for your help

Maybe it hit some internal black list. The 23/8 ip network had been reserved until 2010 and its neighbours are not that friendly (DoD mostly).

To see wheter it is DNS related, change the DHCP Server Config of your LAN interface, under Advanced Options: DHCP-Options. Change it to something like 6,, to distribute the google DNS server and bypass any turris DNS stuff.

For me, there was certainly an element of DNS initially, but changing to dnsmasq fixed that, now it seems to be some sort of issue with the conversation between the scales and (my other devices work fine!)

I’ve raised a ticket with Garmin plus sent them the following pcap file:

Hi, thanks for your suggestion. Unfortunately, using an external DNS like the google’s one didn’t solve the problem. Could it be related to filters and security settings in the Omnia ?
I’ll try to put back my old router and check if the scale is working fine in this setting.
I’ll let you know

I’ve just RMA’ed my scale back to Garmin - they’ve had all the pcap files I have conducted (both br-lan and pppoe-wan, I also sent them pcap’s of my Garmin Edge 1000 talking successfully to the servers, so I think that perhaps rules out the Garmin server side…

Dnsmasq works for the DNS aspect, the scale can get the address of the two places it visits, and - it just seems to not conclude what ever conversation it starts with

I even tries stripping all teh rules out of the firewall but to no avail.

I am really hoping that the replacement Garmin scales will work! I’ll report back when they arrive (in about a week perhaps)

Option to assign different DNS servers to the Garmin included in this thread:

(unable to test as I don’t have the scales at the moment!)

Thanks for the update, just to be sure, updating /etc/config/dhcp is not enough ?
I did this and now, it connects, progress bar then fail…
should I install the custom package ?
I installed wireshark on my laptop but do not see the scale in the trace :frowning:
maybe because of the wifi card ? Is it possible to install it directly on the turris (or other tool to check what’s going on ?)

So my replacement Index Scales arrived from Garmin this week, they came with V2.4 software installed and worked right out of the box. I was worried that the issue might have been the V2.7 software as that is what was on the device I RMA’ed back to Garmin, so didn’t want to report back until it had updated itself to the 2.7.

I can confirm my Scales now work, V2.7 firmware. Nothing changed since my testing before I sent them back.

No information has been provided by Garmin, just a replacement device.

If you still have problems and you are still in warranty - I’d suggest RMA them.


Thanks for the update. Did you apply all the changes (updated package and specific DNS) or did you revert to Turris factory settings with the new scale ?