FTDI not working in rear USB Port

I’ve installed kmod-usb-serial-ftdi package and then connected a Hardwario Radio Dongle to the rear USB port of my Omnia and it wasn’t recognized as a TTY port. And also nothing was listed in lsusb output.

In dmesg I see this output:

[ 1232.252294] usb 4-1: new full-speed USB device number 3 using xhci-hcd
[ 1232.433222] usb 4-1: unable to read config index 0 descriptor/start: -71
[ 1232.439958] usb 4-1: can't read configurations, error -71
[ 1232.592255] usb 4-1: new full-speed USB device number 4 using xhci-hcd
[ 1232.772497] usb 4-1: device descriptor read/all, error -71
[ 1232.778081] usb usb4-port1: attempt power cycle
[ 1233.482162] usb 4-1: new full-speed USB device number 5 using xhci-hcd
[ 1233.512397] usb 4-1: device descriptor read/8, error -71
[ 1233.662722] usb 4-1: device descriptor read/all, error -71
[ 1233.812142] usb 4-1: new full-speed USB device number 6 using xhci-hcd
[ 1233.843407] usb 4-1: unable to read config index 0 descriptor/start: -71
[ 1233.850150] usb 4-1: can't read configurations, error -71
[ 1233.855897] usb usb4-port1: unable to enumerate USB device

When I’ve connected a dongle to a front USB port, everything works fine and ttyUSB0 is available.
I thought that maybe that rear USB port is dead, but I tried to connect USB2 and USB3 flash drives and both of them have been recognized successfully even when connected to the rear port.

Omnia is running the latest TurrisOS 5.1.9 version.

I tried to rollback to a factory version (Turris OS 3.2.1) and the error when connecting the dongle to a rear port is the same one (error -71) as on TOS 5.

Is there anything to check, please?


It might be related to usb hubs. Some devices dont work after being connected to two usb hubs in a row. Just a lucky guess. Chceck dmesg -w when you connect to working usb port.

I have the same problem with Aeon Z-Stick working with cp210x controller.
It usually works in rear usb port, but sometimes it requires series of reboots.
Today I switched it to front port and it works out-of-the-box.
I do not know what is the difference.

I have a SATA-USB frame connected to the rear USB port and it works without a glitch for years. So the port can work correctly at least with some devices. I must note that I don’t use wifi that much (it is running, but most of the time there are no connected devices).

Finally, I managed to replace that Omnia with another temporary router so I can troubleshoot this further without constantly breaking the internet for everyone at home, and that exact BigClown Dongle works now :open_mouth: .

The only difference is that Omnia is on my desk instead of being on a shelf in a rack, so maybe this might be occurring only during higher temperatures? But strange thing is that the front USB port worked always fine even when placed in the rack.

I will keep Omnia running for a longer period of time and try connecting USB dongle later.


Vladimir, are you able to connect to your Omnia via SSH? Which one? I would like you to send me your U-Boot (bootloader) image and also to try another one.

To get your current U-Boot image, connect via ssh and execute this command

dd if=/dev/mtdblock0 of=/root/u-boot-old.bin bs=1M

Afterwards the old U-Boot image will be stored at /root/u-boot-old.bin, and you have to retrieve it from the router, either via scp if you are using Linux on your computer (substitue OMNIA_IP with your Omnia’s IP address)

scp root@OMNIA_IP:/root/u-boot-old.bin /tmp/u-boot-old.bin

this will store it in /tmp/u-boot-old.bin on your computer, or via WinSCP if you are using Windows. Please send me the file afterwards and I will try to prepare another U-Boot image for you.


The Omnia that is having this particular problem is a black one with 1 GB of RAM which should be the CZ11NIC13 revision.

I’ve just sent you a private message with the U-Boot image.

Thank you!