Forwarding all lan traffic through wireguard is not working

I’m hoping some one way more savvy than me can help me out with my wireguard issue. My setup is;
<------> lan/wlan clients.

On turris os3 my setup worked and all clients on my network used the wg tunnel to the vps.
The same config on turris os4 did not work. problem number

  1. Allowed ips failed to connect to wgs-svr, so i tried which did connect to the VPS
  2. Now my omnia and the vps are connected through the wg tunnel I cannot seem to route all traffic through the tunnel. I have tried various recipes from openwrt forum/docs and on this forum but I cannot get traffic to use the tunnel. I have many different configs i’ve tried and can post them here if any body can help. (how do i post configs in the scrollable box in this forum?)
    In the meantime I am going to setup the same thing on a vanilla openwrt mikrotik router to see if I encounter the same problems. If anybody can explain why won’t connect anymore but will I’d appreciate it as I feel that this maybe the root of my routing issue.