Foris Storage -ERROR: not a btrfs filesystem: /srv

I tried to add a SSD as storage to my Mox (Foris 4.0.5)after I previously had problems with an USB stick.
Now I wanted to add the storage using Foris.

Unfortunetaly I am receiving the following error:

How can I resolve this?

Is this stick formated ? (formatting was done correctly ) Try other USB stick …

It is not a stick it is a new SSD in a USB3 case. The stick i used before lost integrity very quickly.

I though the whole point of the storage module was to format the SSD to BTRFS, move contents from /srv/ to the SSD and link it to /srv.

An SSD is not required for /srv. Flash drive is sufficient. How did you do when creating the /srv folder? On the way Foris?

I would consider formatting ssd-usb3 with another tool to check that the formatting btrfs will be done or will not be done correctly.

Or another tool in Windows

After verifying that the formatting is correct, try create /srv again in the Foris menu

Formatting the partition manually has worked:

Unfortunately I still receive the same error in the Foris menu.

I have now managed to add it manually.
However, srv seems to be limited to 50MB.
How Can I change this?

/srv be me


But, Is not better mount point /sdb ??

I have got it working now.
Had to manually remove the existing none mount on /srv by editing /etc/mtab.

in case you formated the drive by your own and not via Foris
, you can look at /etc/config/storage and edit it

config srv 'srv'
    option uuid '<uuid of your /dev/sda>'

get the uuid using this : blkid | grep '/dev/sda' | cut -d ' ' -f3 and use that (without leading UUID=)

and reboot machine foris-storage plugin should be able to get it.

Some guys faced this issue already , so i think no harm, you just need to edit that “storage” config :slight_smile: (if there is wrong UUID or none, mounting process can’t mount it …and you get the error and becasue of /srv might exist as folder in existing mountree with differnt filesystem you get the message …in foris complaining about it

that is also way , or using fstab directly or via luci (but i remember i had some issue some time ago and i had to do it via foris anyway) … there is /etc/rc.d/S40srv (/etc/config/storage) and /etc/rc.d/S40fstab (/etc/config/fstab), mtab (/proc/mounts) is only for actualy used mounts, gone after reboot
unless you have fstab as config somewhere persistently and you do not use the uci “fstab” (resp: you did the “Generate fstab from mtab” using Luci>system>mountpoints .