"Forced update" - DDNS not resolving right. (Help!)

So, I have a DynDNS.org hostname of rjbox.webhop.net.

rjbox.webhop.net is, I believe, supposed to resolve to whatever my current dynamic IP address is.

But my Turris Omnia router, man, that sucker cuts in and out – mostly out – all the freakin’ time.

I’m getting loads of the old "Updater failed: Unknown error" message on the foris home page.

At this point, I have to get to the bottom of this problem, whatever it is.

As you can see from the log below, rjbox.webhop.net isn’t working.

The router – at the moment – is resolving off of the IP number (or at least I think that’s what’s going on), but usually I just can’t connect to the internet at all, and often it connects only for a few seconds now & then, here & there.

On the foris “DNS” page, all three of the following are not checked:
Use forwarding
Disable DNSSEC
Enable DHCP clients in DNS

At the moment, the “Connection test” looks like this:
Test type Status
IPv4 connectivity OK
IPv4 gateway connectivity OK
IPv6 connectivity Error
IPv6 gateway connectivity Error

The relevant LOG entry is below (spaces inserted for better readability):

Details for: myddns_ipv4:

170238 : Detect registered/public IP

170238 : #> /usr/bin/nslookup rjbox.webhop.net >/var/run/ddns/myddns_ipv4.dat 2>/var/run/ddns/myddns_ipv4.err

170243 ERROR : BusyBox nslookup error: ‘1’

170243 : nslookup: can’t resolve ‘(null)’: Name does not resolve
nslookup: can’t resolve ‘rjbox.webhop.net’: Try again

170243 : Detect registered/public IP

170243 : #> /usr/bin/nslookup rjbox.webhop.net >/var/run/ddns/myddns_ipv4.dat 2>/var/run/ddns/myddns_ipv4.err

170252 : Registered IP ‘’ detected
170252 info : Starting main loop at 2018-03-30 17:02
170252 : Detect local IP on 'network’
170252 : Local IP ‘’ detected on network 'wan’
170252 : Forced Update - L: ‘’ == R: ‘’

170252 : #> /usr/bin/curl -RsS -o /var/run/ddns/myddns_ipv4.dat --stderr /var/run/ddns/myddns_ipv4.err --noproxy ‘*’ ‘http://rjbox:54-15-4D-05-4F-E1@members.dyndns.org/nic/update?hostname=rjbox.webhop.net&myip=

170255 : DDNS Provider answered:
_ _
170255 info : Forced update successful - IP: ‘’ send
170255 : Waiting 600 seconds (Check Interval)

So why is the “forced update” happening? Can anyone determine from this log what’s wrong? And what I need to to so that the router actually works and gives me a reliable connection?

Foris v. 96.10
Turris OS v. 3.9 6

firmware v. OpenWrt omnia 15.05 r47055 / LuCI 49c3edd5861fd032fa8379ceda525c27a908a114 branch (git-17.212.24321-49c3edd)

Kernel v. 4.4.119-082ea0f4a4e204b99821bedcb349ed54-0

IPv4 WAN Status:
Type: dhcp
DNS 1:
DNS 2:
Expires: 4h 52m 43s
Connected: 1h 7m 17s

(DNS 1 and 2 are OpenNIC servers (not those of my ISP, which is CableVision’s OptimumOnline): 1 is in NYC; 2 is in New Jersey. These are the OpenNIC servers that are geographically closest to me.
( https://www.opennic.org ))

OK, now, if this is happening because (as I’ve read elsewhere on this forum) of a file in the /tmp directory getting too big, the biggest file in my /tmp dir is “atsha-ps.log”. Size: 249087.

I’m guessing I can delete that file with no bad consequences, so I may do that, but that would only be a temporary solution, which doesn’t cut it. I need a permanent solution.

(Also, I think a big file in /tmp may not be the issue here, but I don’t know for sure.)

Thanks for any tips, advice, or plain old speculation.


root@turris:~# cat /etc/resolv.conf
search lan

I think I should not have to put my DNS nameservers here, since I’ve entered them in Foris -> Status -> Network -> eth1 -> Advanced Settings -> Use custom DNS servers.

Also this:

root@turris:~# cat /etc/config/network

config interface 'loopback’
option ifname 'lo’
option proto 'static’
option ipaddr '’
option netmask ‘’

config globals 'globals’
option ula_prefix ‘fd6f:7658:88d4::/48’

config interface 'lan’
option ifname 'eth0 eth2’
option force_link '1’
option type 'bridge’
option proto 'static’
option ipaddr '’
option netmask '’
option ip6assign ‘60’

config interface 'wan’
option ifname 'eth1’
option proto 'dhcp’
option peerdns '0’
option hostname 'rjbox.webhop.net
option dns ‘’

config interface 'wan6’
option ifname '@wan
option proto ‘dhcpv6’

config switch
option name 'switch0’
option reset '1’
option enable_vlan ‘1’

config switch_vlan
option device 'switch0’
option vlan '1’
option ports ‘0 1 2 3 5’

config switch_vlan
option device 'switch0’
option vlan '2’
option ports ‘4 6’

config interface 'guest_turris’
option enabled '0’
option type 'bridge’
option ifname 'guest_turris_0 guest_turris_1’
option proto 'static’
option ipaddr '’
option netmask '’
option bridge_empty ‘1’


This might be known bug that is fixes in 3.10 release of Turris OS. If it’s then there is nothing too wrong with updates except that check for them fails because of no internet connection.
Other options is not enough ram. That might explain some weird temporally connection problems that router can produce. But overall, I have no idea yet.

Let me ensure that I understand your problem. You are all over the place here but what is core of your problem? You are talking about dyndns but then you say also that your network doesn’t work. So you have problems with network connection or with dyndns? From what I see it can be either one of those. It’s can be possible that your dyndns provider doesn’t correctly signs their domains so they won’t resolve with DNSSEC enabled (but disabling dnssec is a bad idea and it resolved for me). The same way it can be that in that specific moment router just doesn’t have network connectivity or that you isp is doing something nasty to dns traffic. Are all other resolution requests passing fine? Is that network test from same time myddns output? If you run those side by side does both pass or does ddns fail?

No that’s as it suppose to be. All local dns traffic goes trough local dns forwarding resolver. Your custom DNS servers are put to /tmp/resolv.conf.auto and used by dns resolver.
Also you know that you have forwarding disable so you are not using those servers, are you?

You can also try if the dns lookup works when called manually: nslookup rjbox.webhop.net