Firewall problem (fe: DEEPL.COM)

After last Omnia update some webpages stops to work with the following error.
Using differend connection (Mobile connection, different WiFi, VPN profile) it works correctly with no problem.

I am not an expert but I think the problem is in the firewall settings.
I have disabled Adblock in the “Lucy” settings but the problem persists.
Unfortunately I can’t find the correct logs to post a better description of the problem.
Can I ask for advice on how to solve the problem ?

Original load page

Browser Console output
[Error] Vyskytla se chyba SSL. Zabezpečené připojení k serveru nelze vytvořit.
[Error] XMLHttpRequest cannot load due to access control checks.
[Error] Failed to load resource: Vyskytla se chyba SSL. Zabezpečené připojení k serveru nelze vytvořit. (jsonrpc, line 0)

Zařízení Turris Omnia
Sériové číslo 60_______5
Verze reForisu 1.5.0
Verze Turris OS 7.0.0
Větev Turris OS HBS
Verze kernelu 5.15.148

you sure the problem wasnt on´s side? the page wasn´t reachable a day ago or so… but now again is.

I found the problem on April 18, 2024 right after installing the new Turris 7.0.0 operating system.
The condition lasted a few days, then I tried disconnecting Turris and connecting via the backup LAN path.
The tool opened and worked without any problems.
Tried to find some info in the Turris Firewall log but couldn’t find anything.

Now the situation is fixed the tool even with the connection using turris router is working without any configuration changes. I am not sure if dynamic firewall or some other bug could have been involved.
Maybe an dns cache and problem with translation. www2 - > www. I have no idea.

Anyway, now the problem is not manifesting itself.

Thank you for your answers

1 Like

It could be that they had a problem in their DNSSEC configuration and Turris by default rejects responses with wrong DNSSEC content.


good point,
the only interesting thing is the connection with the restart of Turris after the update
We often use the translator, that’s why I found this possible link, Update → Unavailable Service, right after installation

Aha, so it was after the update to 7.0.0 but before restart? In such case, I don’t wonder many things don’t work. This intermediate state is known to be super-unreliable (definitely in major version updates).

1 Like

After Update and Restart

TurrisOS 6.5.2 - hbs - 17. 4. 2024 15:41
TurrisOS 7.0.0 - hbs - 17. 4. 2024 15:50

First problem we identify 17. 4. 2024 16:20

And another reboot resolved the problem?