Findutils-locate broken


#1

Tried to use “locate” command and installed findutils-locate. After installation when trying to initialise with “updatedb” I get the following weird error:

find: unrecognized: -fstype
BusyBox v1.25.1 (2018-10-15 09:14:08 CEST) multi-call binary.

Usage: find [-HL] [PATH]... [OPTIONS] [ACTIONS]

Search for files and perform actions on them.
First failed action stops processing of current file.
Defaults: PATH is current directory, action is '-print'

    -L,-follow      Follow symlinks
    -H              ...on command line only
    -xdev           Don't descend directories on other filesystems
    -maxdepth N     Descend at most N levels. -maxdepth 0 applies
                    actions to command line arguments only
    -mindepth N     Don't act on first N levels
    -depth          Act on directory *after* traversing it

Actions:
    ( ACTIONS )     Group actions for -o / -a
    ! ACT           Invert ACT's success/failure
    ACT1 [-a] ACT2  If ACT1 fails, stop, else do ACT2
    ACT1 -o ACT2    If ACT1 succeeds, stop, else do ACT2
                    Note: -a has higher priority than -o
    -name PATTERN   Match file name (w/o directory name) to PATTERN
    -iname PATTERN  Case insensitive -name
    -path PATTERN   Match path to PATTERN
    -ipath PATTERN  Case insensitive -path
    -regex PATTERN  Match path to regex PATTERN
    -type X         File type is X (one of: f,d,l,b,c,...)
    -perm MASK      At least one mask bit (+MASK), all bits (-MASK),
                    or exactly MASK bits are set in file's mode
    -user NAME/ID   File is owned by given user
    -group NAME/ID  File is owned by given group
    -size N[bck]    File size is N (c:bytes,k:kbytes,b:512 bytes(def.))
                    +/-N: file size is bigger/smaller than N
    -prune          If current file is directory, don't descend into it
If none of the following actions is specified, -print is assumed
    -print          Print file name
    -print0         Print file name, NUL terminated
    -exec CMD ARG ; Run CMD with all instances of {} replaced by
                    file name. Fails if CMD exits with nonzero

Seems that turris is having issues with this package because of weird openwrt directory structure or filesystem or whatever. Would be great if turris team can fix those issue in upcoming relase unless anyone has an idea on how to fix this.

I have seen posts on stackexchange of people that had to change “find” to “gfind” but gfind also doesn’t exists on turris so I didn’t find a solution on how to make it work.


#2

That’s the find command from busybox not recognizing an advanced parameter. Most likely you need to also install real find – the findutils-find package. This seems to be a missing dependency between the two packages.

EDIT: cross-link issue.


Turris OS 3.11 in RC!
#3

That solved it, thanks.