Fiber7 (Switzerland) SFP Compatibility


#41

I have to wait for the modules to arrive. We ordered them last week, so I hope to get them soon. Then I’ll have more to say.

Tomas


#42

OK, the modules have arrived and it is the worst possibility: I cross-connected these two modules (one was plugged into the Omnia board and the other was in Cisco 2960G switch) and it worked for me (using 2m-long SM fiber).

Does your SFP module work when it is plugged in different device than Omnia (for example in a Cisco switch)? If yes, you might have deffective Omnia board. If not, I would suspect the module.

http://aule.elfove.cz/~brill/2016-11-25%2015.20.05.jpg

Tomas


#43

Also on Fiber7 and got my TO today. I have the SFP module from TP-LINK (TL-SM321B)

Looking forward to a solution to ditch the media converter!

Thanks,

E


#44

I have TP-Link TL-SM321B and it doesn’t work in Omnia, but does work in TP-Link media converter. I’ve also tried Lightwin SFP module and it also didn’t work in Omnia. So should I assume that my Omnia board is defective? Are there any way to check it?


#45

Well, the flexOptics SFP module works in the tp-link media converter. Shouldn’t that be enough proof that the module itself works?


#46

I’m in the same situation: my Flexoptic modules works in a tp-link media converter, but i don’t see any Traffic when plugged in the Turris omnia. I think its unlikely that me an sECuRE both have faulty Omnia boards.


#47

My Friend ordered a Turris as well - i will check with his device as well


#48

I have the same issue with a flexOptix module (with official Turris Omnia compatibility). Flashing the latest medkit from 2016-11-21 also makes my Turris reboot endlessly after the initial configuration.


#49

The reboot loop should not happen. At least the image works for me. Have you checked MD5 sum after writing the image to the USB key?


#50

It would be nice to check the module with different Omnia before filling in RMA. However we would like to see one non-functional SFP to check whether it is defective HW.

Yet another idea: Is the connection 1000BASE-BX for sure? I can see that the modules can support 100BASE-BX (which is not suppported on Omnnia side, or at least the software does not support it).


#51

yes, I did check the md5sum of the medkit on the USB stick.


#52

I will have Fiber7 starting around mid-December and will be able to cross-test somebodies SFP with my Turris Omnia, if that helps.


#53

I have also a TP-Link TL-SM321B which works with my TP-Link MC220L media converter but nothing with the omnia. And yes it is a 1000BASE-BX connection to the ISP.


#54

The connection definitely is 1 Gbit/s — in speedtest.net, I’m getting ≈ 960 Mbps down/up :).


#55

Well, it seems to be trickier that only the SFP module compatibility. I got in touch with technicians from Init7 and from FlexOptix as well and we will try to estimate what the problem might be and how to simulate it.

What I have basically done is that I have read through IEEE 802.3-2005 clause 37 to learn about 1000BASE-X auto-negotiation and I’ll try to cross-check mvneta driver with the standard and with the specs from Init7 if they come up with some clues/answers.

I think that it is unlikely that multiple boards would be defective in this way, that would demonstrate solely in Init7 network. Especially because the boards have been tested with SGMII SFP module before packaging - the module has to show link and ping has to succeed in order to mark the board OK. However, it would be great if somebody could test the Omnia board that does not work in Init7 with 1000BASE-BX either with different SFP with another switch or with the reversed -BX module in ordinary switch, to rule out hardware issue.


#56

Btw. there is yet another idea from HW guys: Let’s try to set rate-select pin of the SFP to 1. It is most likely ignored and it has not done anything at all in my setup, but anyway. This should do the job:

echo 506 > /sys/class/gpio/export
echo out > /sys/class/gpio/gpio506/direction
echo 1 > /sys/class/gpio/gpio506/value


#57

Is there any board that works with any SFP with Init7 in Switzerland?

I have the TP-Link rather than the flexoptics SFP however, not sure if it is worth testing anything?


#58

I tried 2 different SFP modules in my omnia (TP-Link TL-SM321B and Lightwin LSFP-WDM-LA20-UNI) both didn’t work with the same messages in log. Unfortunately I can’t try anything different because I have only that equipment.


#59

Hi Brill,

I got the Omnia delivered last week on my Init7 link and seeing exactly same behaviour - TP-Link SFP is flapping once connected. With the MediaConverter it works like a charm. Can give it a try with a Cisco SFP tomorrow evening and let you know the outcome. if you need me to run some test, I’m happy to assist.

rgds Simon


#60

Tried it right after re-flashing to the official latest medkit and before continuing to step 3 in the installation wizard (right after setting the root password).
Unfortunately no change in behaviour, I still get only

[  222.600776] mvneta f1034000.ethernet eth1: Link is Up - 1Gbps/Full - flow control off
[  225.603966] mvneta f1034000.ethernet eth1: Link is Down